Transceive function does not work on NFC_A tag

RESOLVED FIXED in Firefox OS master

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: dimi, Assigned: dimi)

Tracking

unspecified
2.2 S5 (6feb)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-master fixed)

Details

Attachments

(2 attachments)

(Assignee)

Description

4 years ago
Transceive function does not work on NFC_A tag, the root cause is that nfcd did not handle connect correctly.
(Assignee)

Comment 1

4 years ago
Created attachment 8553590 [details] [review]
pull request to mozilla-b2g/platform_system_nfcd v1

Hi Yoshi,
The root cause is that the check in handleTagTransceiveResponse in NfcService.cpp is incorrect. Originally the tag technology in nfcd is a little bit mess so i also clean it up.

Combine tag technology defined in NfcGonkMessage and interface/TagTechnology
so for nci internal use of tag technology should be |enum TechnologyType|.
for general tag type will then be |enum TagTechnology|
Attachment #8553590 - Flags: review?(allstars.chh)
(Assignee)

Comment 2

4 years ago
Comment on attachment 8553590 [details] [review]
pull request to mozilla-b2g/platform_system_nfcd v1

Will work on bug 1089658 first then rebase on it
Attachment #8553590 - Flags: review?(allstars.chh)
(Assignee)

Comment 3

4 years ago
Comment on attachment 8553590 [details] [review]
pull request to mozilla-b2g/platform_system_nfcd v1

Set r? to yoshi because actually this bug is not really related to NFC_A, this is an internal bug of nfcd so this patch should also be uplift to 2.2
Attachment #8553590 - Flags: review?(allstars.chh)
Attachment #8553590 - Flags: review?(allstars.chh) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Master: https://github.com/mozilla-b2g/platform_system_nfcd/commit/13374490fc0c989347448f0b2d6b220adff5e630
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-b2g-master: --- → fixed
Keywords: checkin-needed
Resolution: --- → FIXED
(Assignee)

Comment 5

4 years ago
Created attachment 8555065 [details] [review]
pull request to mozilla-b2g/platform_system_nfcd 2.2
You need to log in before you can comment on or make changes to this bug.