Closed Bug 1125070 Opened 5 years ago Closed 5 years ago

[RTL][Settings]The app icons in Location Accuracy list is not mirrored.

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S6 (20feb)
feature-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: lulu.tian, Assigned: eragonj)

Details

(Keywords: privacy)

Attachments

(3 files)

Attached image appicons.png
[1.Description]:
[RTL][Settings]Launch Settings -> Privacy Panel -> Location Accuracy -> Add exceptions, the app icons in Location Accuracy list is not mirrored.
Found time:15:10
See attachment:appicons.png and logcat_1510.txt

[2.Testing Steps]: 
Prerequisite: Set the system language as Arabic.
1. Launch Settings.
2. Select Privacy Panel -> Location Accuracy -> Add exceptions.
3. Observe the list.

[3.Expected Result]: 
3. The app icons in list should be mirrored.

[4.Actual Result]: 
3. The app icons in Location Accuracy list is not mirrored.

[5.Reproduction build]: 
Flame 2.2 build:
Gaia-Rev        e4f9b5da3751798f9cc5d95f302c30722cc11fca
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/4a90da67661e
Build-ID        20150122002808
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150122.041326
FW-Date         Thu Jan 22 04:13:37 EST 2015
Bootloader      L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
QA Whiteboard: [rtl-impact]
Attached file logcat_1510.txt
Adding privacy keyword.
QA Whiteboard: [rtl-impact] → [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(pbylenga)
Keywords: privacy
Assignee: nobody → fabien
This is Kaze's fault.
Assignee: fabien → nobody
feature-b2g: --- → 2.2+
Flags: needinfo?(fabien)
Priority: -- → P2
Assignee: nobody → fabien
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(pbylenga)
I confirm, shame on me!
Flags: needinfo?(fabien)
The apps in Applications and Permissions items also have this problem.
STR:
1. Launch Settings.
2. Select Privacy Panel -> Transparency Control -> Applications or Permissions.
**All apps in item which under Applications and Permissions are not mirrored.
Hi Fabien, you still working on this? thanks.
Flags: needinfo?(fabien)
Hi Howie, feel free to steal this bug if you want. I have a couple priorities to address first, so I’m not likely to work on this on the next day or two.
Flags: needinfo?(fabien)
I can help this one.
Assignee: fabien → ejchen
Comment on attachment 8561816 [details] [review]
[PullReq] EragonJ:bug-1125070 to mozilla-b2g:master

Hi Marta,

would you mind help me check this patch ? Thanks !
Attachment #8561816 - Flags: review?(marta)
Attachment #8561816 - Flags: review?(marta) → review+
Thanks all, this patch was merged into Gaia/master : https://github.com/mozilla-b2g/gaia/commit/28bd6232944f7266fab29c99c917f4df119659ae
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8561816 [details] [review]
[PullReq] EragonJ:bug-1125070 to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): no
[User impact] if declined: for RTL users, app icons would get overlapped with the the other stuffs on the screen.
[Testing completed]: no, only css change.
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: no
Attachment #8561816 - Flags: approval-gaia-v2.2?
Attachment #8561816 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed on the latest Nightly Flame 3.0 and Flame 2.2 builds.

Actual Results: The icons are correctly mirrored in RTL languages.

Environmental Variables:
Device: Flame 3.0 KK (319MB) (Full Flash)
BuildID: 20150220010206
Gaia: e4f7c67378e33e83f88d38ddb4a6c2cabf1423c3
Gecko: 1b4c5daa7b7a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Environmental Variables:
Device: Flame 2.2 KK (319MB) (Full Flash)
BuildID: 20150220002501
Gaia: ce79d35b92261e7cbfeaefebf87859ebeb0979b4
Gecko: b864abe1c6b3
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15739/
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.