Closed Bug 1125071 Opened 5 years ago Closed 5 years ago

[RTL][Calendar]The bottom of Month view and the Day view will display as black page.

Categories

(Firefox OS Graveyard :: Gaia::Calendar, defect, P1, major)

ARM
Gonk (Firefox OS)

Tracking

(feature-b2g:2.2+, b2g-v2.2 affected)

RESOLVED WORKSFORME
feature-b2g 2.2+
Tracking Status
b2g-v2.2 --- affected

People

(Reporter: lulu.tian, Unassigned)

References

Details

Attachments

(2 files)

Attached image calendarview.png
[1.Description]:
[RTL][Calendar]Change the Month view to Day view; Back to Month vies and change to Day view again, the bottom of Month view and the Day view will display as black page.
Found time:17:18
See attachment:calendarview.png and logcat_1718.txt

[2.Testing Steps]: 
Prerequisite: Set system language as Arabic.
1. Launch Calendar app.
2. Change to Day view.
3. Change to Month view.
4. Change back to Day view.


[3.Expected Result]: 
3. The bottom of Month view should display correctly and clearly.
4. The Day view should display correctly and clearly.

[4.Actual Result]: 
3. The bottom of Month view displays as black page.
4. The Day view displays as black page.

[5.Reproduction build]: 
Flame 2.2 build:
Gaia-Rev        e4f9b5da3751798f9cc5d95f302c30722cc11fca
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/4a90da67661e
Build-ID        20150122002808
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150122.041326
FW-Date         Thu Jan 22 04:13:37 EST 2015
Bootloader      L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
QA Whiteboard: [rtl-impact]
Attached file logcat_1718.txt
This seems pretty bad. Nominating since this breaks Calendar view
blocking-b2g: --- → 2.2?
Priority: -- → P1
RTL update: marking required bugs as feature-b2g:2.2+ (and removing blocking flags)
blocking-b2g: 2.2? → ---
feature-b2g: --- → 2.2+
Dear Jacob,
Can you help to find someone help on this bug?
Thanks!
Flags: needinfo?(jshen)
if you notice the statusbar is also broken, so this is definitely not a Calendar issue.
maybe this got fixed together with Bug 1121748?
See Also: → 1121748
(In reply to Josh Cheng [:josh] from comment #4)
> Dear Jacob,
> Can you help to find someone help on this bug?
> Thanks!

Josh, can you follow u Miller's theory on 1121748?  Thanks - Jacob
Flags: needinfo?(jocheng)
Flags: needinfo?(jshen)
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15238/
Flags: in-moztrap+
This issue can not be repro on latest build of Flame v2.2, if anyone can repro it, reopen again.
Rate:0/5

Flame 2.2 build:
Build ID               20150208002500
Gaia Revision          e827781324cbde91d2434b388f5dead3303a85ee
Gaia Date              2015-02-06 20:54:14
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0552759956d3
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150208.035623
Firmware Date          Sun Feb  8 03:56:34 EST 2015
Bootloader             L1TC000118D0
Status: NEW → RESOLVED
Closed: 5 years ago
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
Resolution: --- → WORKSFORME
Flags: needinfo?(jocheng)
You need to log in before you can comment on or make changes to this bug.