Sync no longer syncs all tabs

RESOLVED DUPLICATE of bug 1244622

Status

()

Firefox
Sync
RESOLVED DUPLICATE of bug 1244622
3 years ago
a year ago

People

(Reporter: kael, Unassigned)

Tracking

({testcase-wanted})

37 Branch
x86
Windows 8.1
testcase-wanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
In the past few days, Sync stopped syncing all my tabs. Previously if I used about:sync-tabs I could see all the tabs I had open on every machine. I could double-tap one to open it locally, at which point it would disappear from the list of remote tabs.

Now, only a tiny subset of the tabs from each machine appears in the sync-tabs list. My main desktop has something like 30 tabs open yet only around 8 appear in the sync-tabs list on my laptop. I've tried restarting each FF instance along with forcing a manual sync to no avail. If I open new tabs right now they *do* appear in the sync-tabs list, and if I close one of the tabs from the list it goes away - so tab syncing is at least partially functional.
(Reporter)

Updated

3 years ago
Hardware: x86_64 → x86
(Reporter)

Comment 1

3 years ago
The easiest way for me to repro this is to restart FF on my desktop then Sync. Most of my tabs disappear from the sync-tabs list.

If I manually select the tabs on the desktop so they load, then force a Sync again, that usually makes them reappear on the list. So I think this might be as simple as tabs disappearing from sync until they've been manually loaded by selecting them?

Pinned tabs don't sync either, but that's a known caveat, I think?

Updated

2 years ago
Priority: -- → P1
Keywords: testcase-wanted
Priority: P1 → --
(Reporter)

Comment 2

a year ago
Created attachment 8775806 [details]
Desktop tabs list (some tabs not visible because the list scrolls)

I don't have a reliable test case for this, but it's consistently broken. My home desktop typically has upwards of 50 tabs open, with sync enabled and working...
(Reporter)

Comment 3

a year ago
Created attachment 8775807 [details]
Sync-tabs from tablet

And here's the synced tabs page from my windows tablet after I forced a sync. The most recently opened/visited tabs are there, but nothing else.
Thanks for the explanation. We do limit the number of tabs to 50, and bug 1244622 exists to offer some way to see a larger amount - hopefully we will get some traction on that soon.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1244622
You need to log in before you can comment on or make changes to this bug.