KidFox: Restricted profiles - Hide all Guest Browsing features and related UI

RESOLVED DUPLICATE of bug 1125312

Status

()

Firefox for Android
Profile Handling
RESOLVED DUPLICATE of bug 1125312
4 years ago
3 years ago

People

(Reporter: jchaulk, Assigned: sebastian)

Tracking

Trunk
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Comment hidden (empty)
Blocks: 1125710
OS: Windows 8.1 → Android
Hardware: x86_64 → All
Version: unspecified → Trunk
(Reporter)

Updated

4 years ago
Blocks: 1125984
(Assignee)

Updated

3 years ago
Assignee: nobody → s.kaspari
Status: NEW → ASSIGNED
(Assignee)

Comment 1

3 years ago
I wonder if this is already achieved by bug 1125312 (Hiding 'tools' sub menu). Is there any other way to enter a guest session?
(In reply to Sebastian Kaspari (:sebastian) from comment #1)
> I wonder if this is already achieved by bug 1125312 (Hiding 'tools' sub
> menu). Is there any other way to enter a guest session?

There is no other way via the UI. It is possible to launch fennec via ADB, sending some extras, and open in guest browsing. I don't think we should worry about that for now.

If we did care, there is probably a place in BrowserApp (maybe GeckoApp) where we look for the -guest flag.
Just for completeness, once you are alrwady in Guest Browsing, there is additional UI:
1. Tools > Exit Guest Session
2. System notification for Exit Guest Session

#1 is already covered. #2 is not, but since it's only for exiting guest browsing we should be OK ignoring it for now.
(Assignee)

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1125312
You need to log in before you can comment on or make changes to this bug.