crash in js::jit::JitProfilingFrameIterator::tryInitWithPC(void*), with Gecko Profiler extension & e10s disabled, when loading Google Map data-visualization

RESOLVED DUPLICATE of bug 1124070

Status

()

--
critical
RESOLVED DUPLICATE of bug 1124070
4 years ago
4 years ago

People

(Reporter: vladan, Unassigned)

Tracking

({crash, regression})

Trunk
crash, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

4 years ago
This bug was filed from the Socorro interface and is 
report bp-9ff00bd5-aef0-4810-a209-07a3f2150123.
=============================================================

I got this crash twice while idling on GMail with profiler enabled on the latest Nightly 38 (23-01-2015) on Windows 7
I just hit this twice in a row, also with profiler enabled. (The second one being a startup crash, a few seconds after restoring my tabs after recovering from the first crash.)
bp-ececbbf8-a87e-4ad0-8ca2-2dfff2150126
bp-286ca817-d738-413f-9cc7-92e862150126

I seem to hit this reliably when I click the "interactive map" link on this page, with the Gecko Profiler addon installed:
https://www.eff.org/deeplinks/2015/01/what-we-learned-oakland-raw-alpr-data
(I also have e10s disabled, which may or may not matter.)
Here's the link directly to the "interactive map":
https://www.google.com/fusiontables/DataSource?docid=1dEEIyxvxaN4upYLz835XnfO-fC1ZVy86AY3wz7zd#map:id=3

I've just verified that this URL crashes my browser on load, if I've installed the Gecko Profiler Addon and disabled e10s. (I started with a fresh profile, too, so those seem to be the only required factors.)
Regression range:
Last good revision: cac6192956ab (2015-01-16)
First bad revision: 369a8f14ccf8 (2015-01-17)
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cac6192956ab&tochange=369a8f14ccf8

Looks likely to be a regression from bug 1057082, whose commit messages all mention a "new profiler implementation".
Blocks: 1057082
OS: Windows NT → All
Hardware: x86 → All
Summary: crash in js::jit::JitProfilingFrameIterator::tryInitWithPC(void*) → crash in js::jit::JitProfilingFrameIterator::tryInitWithPC(void*), with e10s disabled, when loading e.g. Google Map data-visualization
Version: 38 Branch → Trunk
Keywords: regression
Flags: needinfo?(kvijayan)
Summary: crash in js::jit::JitProfilingFrameIterator::tryInitWithPC(void*), with e10s disabled, when loading e.g. Google Map data-visualization → crash in js::jit::JitProfilingFrameIterator::tryInitWithPC(void*), with Gecko Profiler extension & e10s disabled, when loading Google Map data-visualization
I'm pretty sure this is a dup of 1124070.  There's a patch up and pending review.
Flags: needinfo?(kvijayan)
That's great news! Marking as dependency for now; feel free to dupe etc. as-appropriate.
Depends on: 1124070
FWIW, I just hit this when loading a Google Calendar page:
 bp-25c51e09-9f41-4f47-a5a6-4514b2150128
and also a page on the "NextDoor" social network:
 bp-86f89feb-6001-4642-8898-ddc142150128
I'm reasonably sure that this is a dup of 1124070.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1124070
I verified that I can load the URL from comment 2 without crashing (with e10s disabled & gecko profiler addon installed). So, yup, looks like this is fixed, presumably by that bug. Thanks!

Nightly 38.0a1 (2015-02-04)
You need to log in before you can comment on or make changes to this bug.