let users add item to reading list before the page is fully loaded

RESOLVED DUPLICATE of bug 1127445

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 1127445
4 years ago
2 years ago

People

(Reporter: edwong, Unassigned)

Tracking

35 Branch
All
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
As a mobile user, I want to add an item to my list before it's fully loaded, especially if I'm on 3G or slower cel data.  My flow is to see a headline I like, but I want to save it off right away since I found it on another social feed and I'm just collecting headlines essentially. Having to wait reduces the value of the reading list (RL) and also, the fact that the book icon doesn't display till the page is loaded makes add to RL harder to find.

One solution to this is to flip the controls to add to RL:

Current:
tap to view in Reader Mode
long press to add to Reading List

Proposed:
tap to add to Reading List. Which doesn't require page to be loaded, just the URL defined.
long press to view in reader mode.  This is more intuitive because I've read some of the article, but it's long and too hard to read... Now I long press to enter a different reading mode. Long press again to exit, or 'x' to jump out?
As part of bug 1123102, we want to decouple the concept of reader mode and reading list, and as part of that, we should implement a way to add a page to your reading list without needing the reader mode icon.
Depends on: 1123102
Severity: normal → enhancement
Summary: [feature request] let users add item to reading list before the page is fully loaded → let users add item to reading list before the page is fully loaded
Actually, this will probably be addressed by bug 1127445. If we have a permanent piece of UI for adding things to the reading list, I imagine users could use it at any point during page load.
Depends on: 1127445
No longer depends on: 1123102
See Also: → bug 1135395
(In reply to :Margaret Leibovic from comment #2)
> Actually, this will probably be addressed by bug 1127445. If we have a
> permanent piece of UI for adding things to the reading list, I imagine users
> could use it at any point during page load.

Yep, addressed by bug 1127445 which just landed in Nightly. I think bug 1134927 also addresses this issue.

Edwin, feel free to reopen if you think this issue can be further addressed.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1127445
You need to log in before you can comment on or make changes to this bug.