[Dialer] Double Tapping the Add Contact button will bring up the context menu twice.

VERIFIED FIXED in 2.2 S7 (6mar)

Status

defect
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: Marty, Assigned: mancas)

Tracking

({regression})

unspecified
2.2 S7 (6mar)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], )

Attachments

(2 attachments)

Reporter

Description

5 years ago
Description:
After the user has typed a phone number into the dial pad, if they double tap the Add Contact  button, two context menus will open.  One over top of another.
   
Repro Steps:
1) Update a Flame device to BuildID: 20150123010227
2) Open the Dialer app and input a phone number into the keypad
3) Double Tap the Add Contact button
4) Press Cancel to dismiss the context menu

Actual:
Two context menus are opened when double tapping the Add Contact button.
  
Expected: 
Only one context menu is opened when double tapping the Add Contact button.

Environmental Variables:
Device: Flame 3.0 Master (319MB)(Full Flash)
BuildID: 20150123010227
Gaia: cba2f0bf49b882e0044c3cc583de8fcf83d2ffa4
Gecko: 494632b9afed
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0 Master)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
  
Repro frequency: 5/5
See attached: video clip (URL), logcat

-------------------------------------

This issue DOES occur on Flame 2.2.
Two context menus are opened when double tapping the Add Contact button.

Environmental Variables:
Device: Flame 2.2 (319Mb)(Kitkat)(Full Flash)
BuildID: 20150123002505
Gaia: 237008137f6d72b9cad25ff4faff14ff2c40ac63
Gecko: be24dd482a83
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

-------------------------------------

This issue does NOT occur on Flame 2.1.
Only one context menu is opened when double tapping the Add Contact button. The second tap will often select one of the context menu options.

Environmental Variables:
Device: Flame 2.1 (319Mb)(Kitkat)(Full Flash)
Build ID: 20150123001230
Gaia: 234ec27050481f4787f1f4750ec26f62ce5cc2c0
Gecko: 4cdcc0e85fc0
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Reporter

Updated

5 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Marty, what's the user impact here?  For example: If we add to an existing contact, return and add to a different contact, what happens?  Looking to determine severity of the issue.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga) → needinfo?(mshuman)
Keywords: regression
Reporter

Comment 2

5 years ago
Impact is not severe.  Adding the same number to multiple contacts in this manner behaves the same as if the user had created a new contact in the settings app with a duplicate number.  This is only a presentation issue where the menu can be opened multiple times, potentially confusing the user.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(mshuman) → needinfo?(pbylenga)
NI on component owner for nomination decision and assignment.  It's a regression with minor impact to the user, could be nominated for polish.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(jlorenzo)
[Blocking Requested - why for this release]: I agree this is a polish but I see a couple of reasons for nominating it:
* This regression was caught early after the 2.2 branching
* It's really easy to reproduce it
* It may confuse an end user if he cancels the first window
* If will effectively confuse this user if he/she adds a new contact and gets displayed the modal window again after.
blocking-b2g: --- → 2.2?
Flags: needinfo?(jlorenzo)
Triage: Regression. Seems like bug 1125369 which is also a blocker.
blocking-b2g: 2.2? → 2.2+
See Also: → 1125369
Assignee

Comment 6

4 years ago
Taking this bug. When we land bug 1125369, I will take care of this issue
Assignee: nobody → b.mcb
Depends on: 1125369
Assignee

Comment 8

4 years ago
Comment on attachment 8570367 [details] [review]
[gaia] mancas:bug1125409 > mozilla-b2g:master

Hey etienne, could you review this patch when you get a chance?

Thanks =)
Attachment #8570367 - Flags: review?(etienne)
Attachment #8570367 - Flags: review?(etienne) → review?(drs.bugzilla)
Attachment #8570367 - Flags: review?(drs.bugzilla) → review+
Assignee

Updated

4 years ago
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8570367 [details] [review]
[gaia] mancas:bug1125409 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): No regression
[User impact] if declined: If user tap multiple times the button, a few dialogs will be shown
[Testing completed]: Manual testing. Unit testing is not needed, just a CSS class was added
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]:None
Attachment #8570367 - Flags: approval-gaia-v2.2?
Target Milestone: --- → 2.2 S7 (6mar)
Attachment #8570367 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed on Flame Master and 2.2.

Result: The context menu only appears once even if the add contact button is double-tapped.
 
Device: Flame Master (KK, 319mb, full flash)
Build ID: 20150310010227
Gaia: 2fb09da0cb9cefad9c6e40f57533fafda6d12557
Gecko: 6686aacf006f
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150310002536
Gaia: 166491b92278dc9e648f8d49ab02d9ca00d74421
Gecko: 1cda026f8996
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2)
Firmware Verson: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.