talos fails to print local.json when in --develop mode

RESOLVED FIXED

Status

Testing
Talos
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jmaher, Assigned: Ankit Goyal, Mentored)

Tracking

Trunk
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good next bug][lang=python])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
it appears we are missing out on printing out local.json (we do get local.out) when running talos.

talos -e /home/jmaher/mozilla/mozilla-inbound/obj-x86_64-unknown-linux-gnu/dist/bin/firefox -a tsvgx --develop


Completed test tsvgx: 
		Stopped Fri, 23 Jan 2015 18:14:33
cycle time: 00:05:59
qm-pxp01: 
		Stopped Fri, 23 Jan 2015 18:14:33
INFO : Outputting talos results => {'results_urls': ['local.out'], 'datazilla_urls': ['local.json']}
DEBUG : Working with test: tsvgx
Generating results file: tsvgx: 
		Started Fri, 23 Jan 2015 18:14:33
Generating results file: tsvgx: 
		Stopped Fri, 23 Jan 2015 18:14:33
INFO : Outputting datazilla results to local.json
Traceback (most recent call last):
  File "run_tests.py", line 305, in <module>
    main()
  File "run_tests.py", line 302, in main
    sys.exit(run_tests(parser))
  File "run_tests.py", line 276, in run_tests
    talos_results.output(results_urls, **results_options)
  File "/home/jmaher/mozilla/talos/talos/results.py", line 76, in output
    _output.output(results, url, tbpl_output)
  File "/home/jmaher/mozilla/talos/talos/output.py", line 420, in output
    utils.info("TALOSDATA: %s" % json.dumps(results.datasets()))
  File "/usr/local/lib/python2.7/dist-packages/dzclient/client.py", line 136, in datasets
    'revision': self.revision[:50],
TypeError: 'NoneType' object has no attribute '__getitem__'
jmaher@jmaher-ThinkPad-X230:~/mozilla/talos/talos$
(Reporter)

Comment 1

3 years ago
I have a hard time reproducing this.  I suspect when I test with `which firefox`, I have to locally hack out the revision and repository from the information since it isn't available, that would explain what probably happened here.
(Assignee)

Comment 2

3 years ago
Talos is using mozversion to get repository and sourcestamp(revision).
And mozversion fetches this data from application.ini present in firefox parent directory.
See application.ini of nighty build and firefox release install(may be in /usr/lib/firefox), some required metadata is absent in firefox release.

What i think we can do here is:
1. Put check in datazilla
2. Put a dummy value in browser_config['sourcestamp']
(Reporter)

Comment 3

3 years ago
Ankit, thanks for the info.  I keep running into a case locally where there is no application.ini.  I think your idea for #2 is a good one, want to take a stab at it?
(Assignee)

Comment 4

3 years ago
Created attachment 8555667 [details] [diff] [review]
Bug 1125415 - talos fails to print local.json when in --develop mode. r=jmaher
Attachment #8555667 - Flags: review?(jmaher)
(Reporter)

Comment 5

3 years ago
Comment on attachment 8555667 [details] [diff] [review]
Bug 1125415 - talos fails to print local.json when in --develop mode. r=jmaher

Review of attachment 8555667 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #8555667 - Flags: review?(jmaher) → review+
(Reporter)

Comment 7

3 years ago
Thanks Ankit!
Assignee: nobody → ankit.goyal90
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.