[Cost Control][Usage] Show browser traffic in its own category inside the application breakdown

VERIFIED FIXED in 2.2 S6 (20feb)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: salva, Assigned: mai)

Tracking

unspecified
2.2 S6 (20feb)
x86_64
Linux
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(5 attachments)

As the browser is integrated in System app, in the application breakdown, the browsing traffic is accumulated inside System app. This UX is misleading so it's necessary to create a separated category labelled `Browsing` to only count browsing traffic.
Summary: [Cost Control][Usage] Show browser traffic in its own category inside applicatin breakdown → [Cost Control][Usage] Show browser traffic in its own category inside the application breakdown
Hi Marina and Salva,

Bug 1070944 was finally landed!
It is landed in mozilla-central and I'll request to uplift to b2g37 as well.

Just a reminder:
1. We should add back "browser app" into the cost control app.
2. The usage of the system app should not include the usage of the browser app.

Please let me know if you have questions. :)
Assignee

Comment 3

4 years ago
Posted file patch v1.0
Hi,
would you mind to give me your feedback?
Regards
Attachment #8564080 - Flags: feedback?(salva)
Comment on attachment 8564080 [details] [review]
patch v1.0

Approach looks great to me. Continue with the changes and ask for my review when ready.

Thank you Mai!
Attachment #8564080 - Flags: feedback?(salva) → feedback+
Assignee

Comment 5

4 years ago
Comment on attachment 8564080 [details] [review]
patch v1.0

Would you mind reviewing the patch?
Attachment #8564080 - Flags: review?(salva)
Comment on attachment 8564080 [details] [review]
patch v1.0

LGTM. Just a little nit on GitHub. Wait for Treeherder to be green and you can merge.

Thank you Mai!
Attachment #8564080 - Flags: review?(salva) → review+
Assignee

Comment 7

4 years ago
Master: fed55d3d89a5cad04a5c30dc6539933fd6577715
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S6 (20feb)
Assignee

Comment 8

4 years ago
Comment on attachment 8564080 [details] [review]
patch v1.0

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Feature
[User impact] if declined: The browser traffic is showed into system app
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): low risk
[String changes made]: Yes
Attachment #8564080 - Flags: approval-gaia-v2.2?(release-mgmt)
:ktucker , can you help verify this on a 3.0 build?
Flags: needinfo?(ktucker)
Keywords: verifyme
This issue is verified fixed on Flame 3.0 master nightly user build. Browser traffic is now listed as 'Browser' and not as 'Other' (system).

Note: Traffic numbers don't seem to add up though. Looking into bugging this. See screenshot.

Device: Flame 3.0 Master (full flash 319MB mem)
BuildID: 20150220010206
Gaia: e4f7c67378e33e83f88d38ddb4a6c2cabf1423c3
Gecko: 1b4c5daa7b7a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Leaving verifyme tag for 2.2 uplifting.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
My mistake on comment 10, the breakdown only shows cellular data usage and it doesn't include wifi usage. The app is showing correct usage.
Attachment #8564080 - Flags: approval-gaia-v2.2?(release-mgmt) → approval-gaia-v2.2+
So glad to see this bug is fixed!
Thanks Marina and Salva! :)
Assignee

Updated

4 years ago
Flags: needinfo?(marina.rodrigueziglesias)
This issue has been verified as pass on latest build of flame2.2 & nexus5 2.2, Browser traffic is now listed as 'Browser' and not as 'Other' (system).
Rate:0/5
Device: N5_2.2[pass]
Build ID               20150705002505
Gaia Revision          ea11f422b687a982f0a961c9aea7858066561707
Gaia Date              2015-07-02 23:37:50
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c0214b4c1ea0
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150705.041046
Firmware Date          Sun Jul  5 04:11:05 EDT 2015
Bootloader             HHZ12f

Device: Flame 2.2[pass]
Build ID               20150705002505
Gaia Revision          ea11f422b687a982f0a961c9aea7858066561707
Gaia Date              2015-07-02 23:37:50
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c0214b4c1ea0
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150705.040440
Firmware Date          Sun Jul  5 04:04:51 EDT 2015
Bootloader             L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.