[FTE][SIM pin] The user is shown the incorrect amount of tries left to enter in a proper SIM pin

VERIFIED FIXED in 2.2 S5 (6feb)

Status

defect
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: dharris, Assigned: mikehenrty)

Tracking

({regression})

unspecified
2.2 S5 (6feb)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing][systemsfe], )

Attachments

(2 attachments)

Description:
When the user attempts the unlock there SIM pin, and fails 2 times, they will have an improper amount of tries left shown next to

Prerequisites: Have a SIM card with a SIM pin in the device

Repro Steps:
1) Update a Flame to 20150126010231
2) Reset or flash the device to access the FTE
3) Tap "Next" on the language selection screen
4) When prompted to enter in the SIM pin, type in the wrong SIM 2 times
5) Observe the number of tries left next to where it says "SIM 1 PIN"

Actual:
It says 2 tries left, but the message below says "You have one try let to enter the correct code before locking..."

Expected:
The text says "1 try left" to match what is said in the message below

Environmental Variables:
Device: Flame 3.0 (319Mb)(Kitkat)(Full Flash)
BuildID: 20150126010231
Gaia: 0f662dffef27599443cfcd790c2b39190a2b35c8
Gecko: fa91879c8428
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro frequency: 15/15 100%
See attached: Logcat, Video - http://youtu.be/UwIef_7ofAk
This issue DOES reproduce on Flame 2.2

It says 2 tries left, but the message below says "You have one try let to enter the correct code before locking..."

Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150126002536
Gaia: 0518f4581a0925c0b703d730ef289ab15cbd1216
Gecko: c6aa604a7967
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

================================================================================

This issue does NOT reproduce on Flame 2.1

The user is shown the message "Last Try" after entering in a wrong SIM pin 2 times

Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat)(Full Flash)
BuildID: 20150126001827
Gaia: 54d92cc0755e5102223276ab23063b5eee74b514
Gecko: 522d6c980917
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Unable to get a logcat for this bug, due to it happening in the FTE
Functional regression of a core feature creating a bad UX.

Requesting a window.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: ychung
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame 2.2
BuildID: 20141110152350
Gaia: c680e54411a729a2ed040432cec4247fa2a8b44d
Gecko: 2155bafd18ab
Version: 36.0a1 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken Environmental Variables:
Device: Flame 2.2
BuildID: 20141110173750
Gaia: 777ceb12bfcd7baadf0f176df467bf6a1960f9e3
Gecko: be83b3029bf2
Version: 36.0a1 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Last Working Gaia First Broken Gecko: Issue does NOT reproduce 
Gaia: c680e54411a729a2ed040432cec4247fa2a8b44d 
Gecko: be83b3029bf2

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: 777ceb12bfcd7baadf0f176df467bf6a1960f9e3
Gecko: 2155bafd18ab

https://github.com/mozilla-b2g/gaia/compare/c680e54411a729a2ed040432cec4247fa2a8b44d...777ceb12bfcd7baadf0f176df467bf6a1960f9e3

caused by bug 936823
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: ychung
Phaninder, can you take a look at this please? Look like this might have been caused by the work done on bug 936823.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(pasupulaphani)
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing][systemsfe]
regression. broken functionality
blocking-b2g: 2.2? → 2.2+
I'll take a look.
Assignee: nobody → mhenretty
Yeah, it seems bug 936823 caused this and didn't fix the original issue. I'm going to have to back that out here, and take a different approach to bug 936823.
Blocks: 936823
Flags: needinfo?(pasupulaphani)
Comment on attachment 8559566 [details] [review]
[PullReq] mikehenrty:bug-1125962-pin-retries to mozilla-b2g:master

There were actually a couple of bugs here. I ended up backing out bug 936823, and fixing it correctly. But it also seems the "Last chance" message would show up when going from SIM 1 to SIM 2 error entry pages. This patch ensures we reset the entire form and re-show only the appropriate data when getting a sim error. Flagging Sam for FTU review.
Attachment #8559566 - Flags: review?(sfoster)
Comment on attachment 8559566 [details] [review]
[PullReq] mikehenrty:bug-1125962-pin-retries to mozilla-b2g:master

Works for me, thanks.
Attachment #8559566 - Flags: review?(sfoster) → review+
master: https://github.com/mozilla-b2g/gaia/commit/8b02bb90aff3cf3a1d3ac486b6426d411414e52f
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8559566 [details] [review]
[PullReq] mikehenrty:bug-1125962-pin-retries to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Bug 936823

[User impact] if declined:
Inconsistent error messages will appear on the SIM lock screen, which might lead the user to believe they have more retries left than they actually do.

[Testing completed]:
Manually tested of course, added 6 new unit tests.

[Risk to taking this patch] (and alternatives if risky):
The risk is to the error message logic on the SIM pin screen, which was already pretty broken. This should make that logic more robust.

[String changes made]: none.
Attachment #8559566 - Flags: approval-gaia-v2.2?
Target Milestone: --- → 2.2 S5 (6feb)
Attachment #8559566 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This bug has been successfully verified on latest Flame v2.2&3.0.
See attachment: verified_v2.2&3.0.png
Reproduce rate: 0/5

Flame 2.2 (Pass):
Build ID               20150319002500
Gaia Revision          9043c11f699c15bb6072422d1dad6518d1b5ddda
Gaia Date              2015-03-19 01:40:44
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c0442d170bec
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150319.042028
Firmware Date          Thu Mar 19 04:20:38 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 (Pass):
Build ID               20150319160212
Gaia Revision          c39e15f631de80c69467fda0d4ea0bcda9e194ca
Gaia Date              2015-03-18 19:30:04
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cbd0efcd976c
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150319.193329
Firmware Date          Thu Mar 19 19:33:42 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.