crash in OOM | large | mozalloc_abort(char const* const) | mozilla::MP4ContainerParser::ParseStartAndEndTimestamps

RESOLVED DUPLICATE of bug 1102642

Status

()

defect
--
critical
RESOLVED DUPLICATE of bug 1102642
5 years ago
5 years ago

People

(Reporter: marcia, Unassigned)

Tracking

({crash, reproducible})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

This bug was filed from the Socorro interface and is 
report bp-acfaa791-b3cf-4762-91d1-553892150126.
=============================================================

Seen while running with the latest beta: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0 ID:20150122214638 CSet: 5807991ef30a

STR:
1. Start playing https://www.youtube.com/watch?v=SFRSDmJiGjc
2. Minimize the browser

Received this crash report.

Frame 	Module 	Signature 	Source
0 	mozalloc.dll 	mozalloc_abort(char const* const) 	memory/mozalloc/mozalloc_abort.cpp
1 	mozalloc.dll 	mozalloc_handle_oom(unsigned int) 	memory/mozalloc/mozalloc_oom.cpp
2 	mozalloc.dll 	moz_xmalloc 	memory/mozalloc/mozalloc.cpp
3 	xul.dll 	nsTArray_base<nsTArrayInfallibleAllocator, nsTArray_CopyWithMemutils>::EnsureCapacity(unsigned int, unsigned int) 	xpcom/glue/nsTArray-inl.h
4 	xul.dll 	nsTArray_Impl<bool, nsTArrayInfallibleAllocator>::AppendElements<bool>(bool const*, unsigned int) 	xpcom/glue/nsTArray.h
5 	xul.dll 	mozilla::MP4ContainerParser::ParseStartAndEndTimestamps(unsigned char const*, unsigned int, __int64&, __int64&) 	dom/media/mediasource/ContainerParser.cpp
6 	xul.dll 	mozilla::TrackBuffer::AppendData(unsigned char const*, unsigned int, __int64) 	dom/media/mediasource/TrackBuffer.cpp
7 	xul.dll 	mozilla::dom::SourceBuffer::AppendData(unsigned char const*, unsigned int, mozilla::ErrorResult&) 	dom/media/mediasource/SourceBuffer.cpp
8 	xul.dll 	mozilla::dom::SourceBuffer::AppendBuffer(mozilla::dom::TypedArray_base<unsigned char, &js::UnwrapArrayBufferView(JSObject*), &js::GetArrayBufferViewLengthAndData(JSObject*, unsigned int*, unsigned char**)> const&, mozilla::ErrorResult&) 	dom/media/mediasource/SourceBuffer.cpp
9 	xul.dll 	mozilla::dom::SourceBufferBinding::appendBuffer 	obj-firefox/dom/bindings/SourceBufferBinding.cpp
10 	xul.dll 	mozilla::dom::GenericBindingMethod(JSContext*, unsigned int, JS::Value*) 	dom/bindings/BindingUtils.cpp
11 		@0x2582363 	
12 		@0x185f75bf 	
13 		@0x2584c00 	
14 		@0x185f760f 	
15 		@0x2840783 	
16 		@0x2584c00 	
17 		@0x10bc94af 	
18 		@0x2584c00 	
19 		@0x18193fa7 	
20 		@0x2840a3b 	
21 	xul.dll 	EnterBaseline 	js/src/jit/BaselineJIT.cpp
22 	xul.dll 	js::jit::TryAttachCallStub 	js/src/jit/BaselineIC.cpp
23 	xul.dll 	js::jit::ICMonitoredFallbackStub::addMonitorStubForValue(JSContext*, JSScript*, JS::Handle<JS::Value>)
Sure looks like a dupe. I will add this signature. This crash is reproducible on this win 8 machine.
Status: NEW → RESOLVED
Closed: 5 years ago
Keywords: reproducible
Resolution: --- → DUPLICATE
Duplicate of bug: 1102642
No longer blocks: MSE
You need to log in before you can comment on or make changes to this bug.