[SIM Pin] If Airplane Mode is on, the "OK" button on the SIM pin screen does not do anything

VERIFIED FIXED in 2.2 S7 (6mar)

Status

defect
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: dharris, Assigned: apastor)

Tracking

unspecified
2.2 S7 (6mar)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], [systemsfe], )

Attachments

(2 attachments)

Description:
If airplane mode is on while the SIM pin screen is active, the "ok" button does nothing

Prerequisites: Have a SIM card with a SIM pin in the device

Repro Steps:
1) Update a Flame to 20150126010231
2) Unlock the device
3) When prompted to put in a SIM pin, pull down the notification bar and enable airplane mode
4) Enter in the SIM pin and tap "OK"

Actual:
The "OK" button doesnt do anything

Expected:
The "OK" button dismisses the SIM pin prompt, or gives the user an error message informing them that airplane mode is enabled

Environmental Variables:
Device: Flame 3.0 (319Mb)(Kitkat)(Full Flash)
BuildID: 20150126010231
Gaia: 0f662dffef27599443cfcd790c2b39190a2b35c8
Gecko: fa91879c8428
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro frequency: 15/15 100%
See attached: Logcat, Video - http://youtu.be/H8Tb-vV0WEs
This issue happens on all branches of Flame with the v18D-1 base, and happens on the v18D base, as well as v188-1 Base

The "OK" button doesnt do anything

Environmental Variables:
Device: Flame Base v18D-1 (319Mb)(Kitkat)
Build ID: 20150106124450
Gaia: 79f6218c4f30c2739575c3ab800078c2cda135cb
Gecko: d9d4000dd43a3637345a41d716dc97fdd700d715
Version: 32.0 (2.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Environmental Variables:
Device: Flame Base v18D (319Mb)(Kitkat)
Build ID: 20141215191148
Gaia: 79f6218c4f30c2739575c3ab800078c2cda135cb
Gecko: d9d4000dd43a3637345a41d716dc97fdd700d715
Version: 32.0 (2.0)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Environmental Variables:
Device: Flame Base v188-1
Build ID: 20141021162107
Gaia: 8c5c956ee6909408e29f375cc7d843a03d92f3d8
Gecko: 60bf345874982e25236ffb80f41e33fdb8ac94f9
Version: 32.0 (2.0)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
NI on component owner for nomination decision as well as assignment.  Not a regression.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Component: Vendcom → Gaia::Settings
Flags: needinfo?(pbylenga) → needinfo?(gchang)
This might need developer's help for more information.
Flags: needinfo?(gchang) → needinfo?(arthur.chen)
It seems the case has not been handled. Alberto, any ideas?
Flags: needinfo?(arthur.chen) → needinfo?(apastor)
Component: Gaia::Settings → Gaia::System
I think we probably should dismiss the PIN dialog when entering in Flight mode. Asking Ux input here.
Flags: needinfo?(apastor) → needinfo?(rmacdonald)
I agree. If the user turns on flight mode manually, then the dialog should be dismissed on its own. When the user turns off flight mode, they would then be re-prompted. NI'ing Carrie from Comms UX to confirm.
Flags: needinfo?(rmacdonald) → needinfo?(cawang)
Agree on comment 6. Thanks!
Flags: needinfo?(cawang)
It seems the conclusion is to dismiss the PIN dialog when Flight mode.
Flags: needinfo?(arthur.chen)
I think so. Redirect to the owner.
Flags: needinfo?(arthur.chen) → needinfo?(apastor)
Assignee: nobody → apastor
Flags: needinfo?(apastor)
Attachment #8567882 - Flags: review?(alive)
Blocks: 1132397
Comment on attachment 8567882 [details] [review]
[gaia] albertopq:1126082-sim-airplane-dismiss > mozilla-b2g:master

Looks good. Thanks alberto
Attachment #8567882 - Flags: review?(alive) → review+
Keywords: checkin-needed
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing], [systemsfe]
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Blocking a blocker
blocking-b2g: --- → 2.2?
blocking-b2g: 2.2? → 2.2+
Alberto, could you please uplift to v2.2? Thanks.
Flags: needinfo?(apastor)
Comment on attachment 8567882 [details] [review]
[gaia] albertopq:1126082-sim-airplane-dismiss > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): -
[User impact] if declined: The OK button in the PIN dialog does nothing when entering in airplane mode
[Testing completed]: Added unit tests
[Risk to taking this patch] (and alternatives if risky): Only dismissing the dialog when an event is received. Not very risky
[String changes made]: -
Flags: needinfo?(apastor)
Attachment #8567882 - Flags: approval-gaia-v2.2?(release-mgmt)
Comment on attachment 8567882 [details] [review]
[gaia] albertopq:1126082-sim-airplane-dismiss > mozilla-b2g:master

release-mgmt@mozilla.com should be used for Firefox Desktop and Mobile.
Attachment #8567882 - Flags: approval-gaia-v2.2?(release-mgmt) → approval-gaia-v2.2?(bbajaj)
Sorry, just did it because :fabrice redirected the approval to that account yesterday with bug 1132397

'Attachment #8568440 [details] - Flags: approval-gaia-v2.2?(fabrice@mozilla.com) → approval-gaia-v2.2?(release-mgmt@mozilla.com)'

Good to know! Thanks!
Attachment #8567882 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
This issue is verified fixed for the latest Nightly 3.0 and 2.2 builds.

Actual Results: The prompt for SIM pin is dismissed when Airplane mode is turned on.
	
Environmental Variables:
Device: Flame 3.0 KK (Full Flash) (319 MB)
BuildID: 20150303010233
Gaia: c8ed1085a67490a1ecd7f275e5de9487e1b93b1d
Gecko: 0b3c520002ad
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2 KK (Full Flash) (319 MB)
BuildID: 20150303002527
Gaia: 3d188c414e30acc392253d5389a42352fcfbc183
Gecko: c89aad487aa5
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Per comment 19, clear the verifyme tag.
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.