[RTL][Contacts]The check box of duplicate cantacts disappears.

RESOLVED WORKSFORME

Status

P1
normal
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: lulu.tian, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8555119 [details]
contactscheckbox.png

[1.Description]:
[RTL][Contacts]When you add a new contact whose number is same as another saved contact, the check box of duplicate cantacts will disappear.
See attachment:contactscheckbox.png

[2.Testing Steps]: 
Prerequisite: 
1. Set system language as Arabic.
2. Have a contact with phone number "1234".
Steps:
1. Launch Contacts.
2. Tap "+" button to add a contact.
3. Set the new contact with phone number "1234".
4. Tap Done button. 

[3.Expected Result]: 
4. The check box of duplicate contacts should be mirrored and displayed at right of screen.

[4.Actual Result]: 
4. The check box of duplicate contacts disappears.

[5.Reproduction build]: 
Flame 2.2 build:
Gaia-Rev        0518f4581a0925c0b703d730ef289ab15cbd1216
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c6aa604a7967
Build-ID        20150126002536
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150126.042138
FW-Date         Mon Jan 26 04:21:49 EST 2015
Bootloader      L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Can we put this bug under the feature-b2g flag?
Flags: needinfo?(doliver)
See comment 1.
Flags: needinfo?(doliver) → needinfo?(whuang)
triage: P1 for functionality blocker
feature-b2g: --- → 2.2+
Priority: -- → P1
Flags: needinfo?(whuang)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1116803
Woot! Sorry, wrong bug, reopening again.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Created attachment 8559052 [details]
2015-02-04-10-59-03.png

Working for me with latest changes in master
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.