[RTL][Homescreen]Scroll bar on search result view is not mirrored.

RESOLVED DUPLICATE of bug 1119057

Status

P1
normal
RESOLVED DUPLICATE of bug 1119057
4 years ago
4 years ago

People

(Reporter: lulu.tian, Assigned: kaze)

Tracking

unspecified
2.2 S5 (6feb)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 affected)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8555122 [details]
scrollbar.png

[1.Description]:
[RTL][Homescreen]When you input something in Rorket bar, the scroll bar is located at right of screen, it's not mirrored.
See attachment:scrollbar.png

[2.Testing Steps]: 
Prerequisite: Set syetem language as Arabic.
1. Launch Rocket bar.
2. Input any words.
3. Wait for about 2 sec and observe the scroll bar.

[3.Expected Result]: 
3. The scroll bar should be mirrored and locate at left of screen.

[4.Actual Result]: 
3. The scroll bar located at right of screen.

[5.Reproduction build]: 
Flame 2.2 build:
Gaia-Rev        0518f4581a0925c0b703d730ef289ab15cbd1216
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c6aa604a7967
Build-ID        20150126002536
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150126.042138
FW-Date         Mon Jan 26 04:21:49 EST 2015
Bootloader      L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Assignee)

Updated

4 years ago
Assignee: nobody → fabien
triage: P1 for high visibility scroll bars
feature-b2g: --- → 2.2+
Priority: -- → P1
Dale, are you fixing this with your search results rewrite?
Flags: needinfo?(dale)
Whiteboard: [systemsfe]
Homescreen is not the only area affected. There is also Rocketbar search, Browser, Marketplace, Smart Collections and Homescreen. Scroll bar should be mirrored for RTL on these areas and is not, as per UX specs p.16
Should I open up separate bugs for each particular case, or just change the title here to reflect this?
Its not been part of my work so far, but will keep an eye on things I should be doing for it to work good, if there are seperate bugs filed feel free to picg / assign me, cheers
Flags: needinfo?(dale)
Reading the description here, I believe this is a duplicate of bug 1119057. Since there is more information there, duping this one. Feel free to re-open if I am mistaken.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1119057
Target Milestone: --- → 2.2 S5 (6feb)
You need to log in before you can comment on or make changes to this bug.