Weird locking issue in Media Decode thread on youtube [webm]

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: valentin, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Posted file top_output.txt
Lately I've found a lot of HTML5 youtube videos keep getting stuck.
If I do a refresh/hard refresh, it usually gets stuck in the same place.
For example, it usually gets stuck at: http://youtu.be/tuFiC_PzjXY at 1:38
Refreshing and trying again only seems to create more of the media decoding threads.

Attaching output of top -H and a stacktrace of all the theads in gdb.

Using gnome-ubuntu 14.10, and Nightly 38.0a1 (2015-01-27)
(Reporter)

Comment 1

4 years ago
Posted file gdb_output.txt
Blocks: 778617

Updated

4 years ago
Priority: -- → P2
Summary: Weird locking issue in Media Decode thread on youtube → Weird locking issue in Media Decode thread on youtube [webm]

Updated

4 years ago
Priority: P2 → P3
(Reporter)

Comment 3

4 years ago
Note that I switched to a new profile for a while, to get around this bug (it only reproduced on that profile). I went back to the default profile a bit later, and I can't currently reproduce the problem anymore. It was probably resolved by another change. (I am on nightly, btw).

So we can probably close it if no one else can reproduce it.
FWIW I've been having similar problems, also on 64-bit Linux, since upgrading to 37.  It's sporadic, happens on more than just YouTube, and doesn't stop when I close what I think is the offending tab.  Seems to just go for as long as it feels like, no matter what I do.

Glad to hear it's fixed in Nightly, but that's still a few months away for me...  :)
Component: Audio/Video → Audio/Video: Playback
Assuming fixed with the new MSE.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

4 years ago
(In reply to Jean-Yves Avenard [:jya] from comment #5)
> Assuming fixed with the new MSE.
Hasn't happened in a long time, so I assume so. Thanks!
You need to log in before you can comment on or make changes to this bug.