Closed Bug 1126368 Opened 5 years ago Closed 5 years ago

[RTL] "Conference (2)" string is not right-aligned when you have a conference + another call

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect, P2)

x86_64
Linux
defect

Tracking

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S6 (20feb)
feature-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: jlorenzo, Assigned: thills)

References

Details

(Whiteboard: [2.2-bug-bash][planned-sprint c=1])

Attachments

(7 files)

Attached image Screenshot
STR
1. Make a call from the device under test.
2. Receive a call to it.
3. Merge these 2 calls
4. Receive another call, and pick it up.

Actual result
"Conference (2)" is aligned to the left where as it was right-aligned in step 3. See screenshot for details.
[Blocking Requested - why for this release]: RTL is a part of the 2.2 release.
blocking-b2g: --- → 2.2?
QA Whiteboard: [rtl-impact]
feature-b2g: --- → 2.2+
Priority: -- → P2
NI to Delphine for more investigation.
Flags: needinfo?(lebedel.delphine)
Priority: P2 → P1
Clearing the blocking nom as this bug is already tracked under the feature flag.

One note: this bug is an edge case, P1 might be a too high priority.
blocking-b2g: 2.2? → ---
Assignee: nobody → drs.bugzilla
Whiteboard: [2.2-bug-bash] → [2.2-bug-bash][planned-sprint c=1]
Target Milestone: --- → 2.2 S5 (6feb)
Flags: in-moztrap+
After testing and looking into this: I agree that this is and edge case and shouldn't be of a high Priority.
It's a fix that's nice to have but I don't think this should be an actual blocker, FWIW
Flags: needinfo?(lebedel.delphine)
Priority: P1 → P2
Assignee: drs.bugzilla → nobody
Target Milestone: 2.2 S5 (6feb) → 2.2 S6 (20feb)
Assignee: nobody → thills
Attachment #8563608 - Flags: review?(drs.bugzilla)
Comment on attachment 8563608 [details] [review]
[gaia] tamarahills:bugfix/1126368-rtl-conf-othercall-not-rtl > mozilla-b2g:master

I left a question on the PR. Please answer it and then we can proceed.
Flags: needinfo?(thills)
Flags: needinfo?(thills)
Hi Doug,

I adjusted this font size to make it match that of the original call.  I don't think it's mandatory, but you can see more of the 'Conference(2)' text this way.  I attached a couple of screenshots, one with the 'as-is' font size (which has the conference font size larger) and one with the modified font size to match the additional call.

Thanks,

-tamara
Flags: needinfo?(drs.bugzilla)
Comment on attachment 8563608 [details] [review]
[gaia] tamarahills:bugfix/1126368-rtl-conf-othercall-not-rtl > mozilla-b2g:master

(In reply to Tamara Hills [:thills] from comment #10)

We have font/line-height resizing code to handle these cases, and we shouldn't be overriding it. Please check what happens if the 2nd call (in attachment 8566508 [details], the one with a phone number) is with a contact with a short name, e.g. "Doug". If it's the same font size as, or bigger than, the "Conference (2)" text, then this is by design.

Either way, let's remove the `font-size` line in the PR. If there's any weird behavior here, we can file followups.
Flags: needinfo?(drs.bugzilla)
Attachment #8563608 - Flags: review?(drs.bugzilla) → review+
Thank you for the review, Doug. Nominating for 2.2? since this is RTL, and doing bug updates while Taipei team is out for CNY ahead of triage today.
blocking-b2g: --- → 2.2?
Not blocking because this is a P2 and not a P1.
blocking-b2g: 2.2? → ---
https://github.com/mozilla-b2g/gaia/commit/1a5f46e1a618038568ab1f073b0faeb027380eca
https://treeherder.mozilla.org/#/jobs?repo=gaia-try&revision=44306e11f910

NI to myself to ask for 2.2 approval.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(thills)
Resolution: --- → FIXED
Flags: needinfo?(thills)
Flags: needinfo?(thills)
Comment on attachment 8563608 [details] [review]
[gaia] tamarahills:bugfix/1126368-rtl-conf-othercall-not-rtl > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): RTL feature
[User impact] if declined:  RTL user would see the string mis-aligned for the Arabic language
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): low.  CSS changes only
[String changes made]:no
Flags: needinfo?(thills)
Attachment #8563608 - Flags: approval-gaia-v2.2?(release-mgmt)
Attachment #8563608 - Flags: approval-gaia-v2.2?(release-mgmt) → approval-gaia-v2.2+
Issue not verified fixed on Flame 3.0 Nightly

The RTL string "Conference (2)" is not right aligned while 2 merged calls and a non-merged call are connected. The string appears centered.

If only merged call is present the string is right aligned. When string is present when language is LTR the text is left aligned.

Attached a screenshot demonstrating issue still occurs.

Device: Flame 3.0
Build ID: 20150224010314
Gaia: 31ac1cd7a029d5e46dd7c92537b5c973c5d9826e
Gecko: 368c62292249
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
Flags: needinfo?(ktucker)
QA Whiteboard: [rtl-impact] → [QAnalyst-Triage?][failed-verification][[rtl-impact]
QA Whiteboard: [QAnalyst-Triage?][failed-verification][[rtl-impact] → [QAnalyst-Triage+][failed-verification][[rtl-impact]
Flags: needinfo?(ktucker)
This issue has verified successfully on Flame 3.0,2.2.
Attachment:Verify_RTL.png

Flame3.0:

Build ID               20150225010244
Gaia Revision          f6bfd854fe4746f21bc006eac145365e85f98808
Gaia Date              2015-02-24 21:10:44
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0a8b3b67715a
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150225.043702
Firmware Date          Wed Feb 25 04:37:14 EST 2015
Bootloader             L1TC00011880

Flame2.2:

Build ID               20150225002505
Gaia Revision          ca64f2fe145909f31af266b1730874051ba76c78
Gaia Date              2015-02-24 22:06:53
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/16804008c29f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150225.041814
Firmware Date          Wed Feb 25 04:18:25 EST 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][failed-verification][[rtl-impact] → [QAnalyst-Triage+][failed-verification][[rtl-impact],[MGSEI-Triage+]
(In reply to Coler from comment #18)
> This issue has verified successfully on Flame 3.0,2.2.
Please ignore this comment.
Status: VERIFIED → RESOLVED
Closed: 5 years ago5 years ago
QA Whiteboard: [QAnalyst-Triage+][failed-verification][[rtl-impact],[MGSEI-Triage+] → [QAnalyst-Triage+][failed-verification][[rtl-impact]
Attached image Verify2_1126368.png
This issue has been verified to fail on Flame 2.2 and Flame 3.0.
See attachment: Verify2_1126368.png
Reproducing rate:5/5
reproduce steps:
1. Make a call from the device under test.
2. Receive a call to it.
3. Merge these 2 calls
4. Receive another call, and pick it up.

Actual result:
"Conference (2)" is center-aligned.
Expected result:
"Conference (2)" should be right-aligned.

Flame 2.2 build:
Build ID               20150308002503
Gaia Revision          166491b92278dc9e648f8d49ab02d9ca00d74421
Gaia Date              2015-03-06 18:26:27
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a48af0b5a6e4
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150308.052515
Firmware Date          Sun Mar  8 05:25:25 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build:
Build ID               20150308160204
Gaia Revision          fea83511df9ccba64259346bc02ebf2c417a12c2
Gaia Date              2015-03-08 06:36:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/eab4a81e4457
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150308.192120
Firmware Date          Sun Mar  8 19:21:31 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(lebedel.delphine)
Hi Delphine,
Could you help with this bug?
Thank you.
Not sure what action on my side is needed. Patches have landed on master and 2.2 but from what I see in the comments, verifications have always failed.
Lancy: if this is the case, please file a new bug for this issue and nominate for as blocking 2.2, given this one is a feature bg2 2.2+. Thanks!
Flags: needinfo?(lebedel.delphine) → needinfo?(yulan.zhu)
Keywords: regression
See Also: → 1141428
Delphine,

Thank you for your advise, I have submitted a new bug and nominate for as blocking 2.2.
Flags: needinfo?(yulan.zhu)
Don't know why I added regression flag here. Anyways, new issue filed again in Bug 1141428
Keywords: regression
This Problem is verified as "pass" on latest build of Flame 2.2&3.0 by the STR in comment 0.
Actual result: "Conference (2)" is right-aligned now.
See attachment: Verify_Pass_Flame2.2&3.0.png
Rate: 0/5

Device information: 
Flame 2.2 (Pass)
Build ID               20150618162503
Gaia Revision          3414b07dc489976bf510fd8042c0af3b1192c160
Gaia Date              2015-06-16 22:04:56
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/14a1a46b54ab
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150618.195202
Firmware Date          Thu Jun 18 19:52:13 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 (Pass)
Build ID               20150618160206
Gaia Revision          55bac3c151bff4f0ce0e8715962c4676fefb0887
Gaia Date              2015-06-18 16:49:24
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/656ea3bfbb4e
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150618.192643
Firmware Date          Thu Jun 18 19:26:54 EDT 2015
Bootloader             L1TC000118D0

On latest build of Nexus5 2.2&3.0, the issue that "Conference (2)" string overlaps with phone icon still occurs. we have submitted the bug 1170104 to track it. So I've closed and marked this bug as verified-fixed.
Thanks!
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][failed-verification][[rtl-impact] → [QAnalyst-Triage+][failed-verification][[rtl-impact][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.