[RTL] "Call ended" overlaps the phone number on the Call screen when you have multiple calls

VERIFIED FIXED in 2.2 S6 (20feb)

Status

defect
P2
normal
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: jlorenzo, Assigned: thills)

Tracking

unspecified
2.2 S6 (20feb)
x86_64
Linux
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [2.2-bug-bash][planned-sprint c=3])

Attachments

(3 attachments)

Reporter

Description

5 years ago
Posted image Screenshot
Prerequisites: 
Set the phone in Arabic.

STR
1. Make a call from the device under test
2. Receive a call to the device under test and pick it up
3. From the other device (from step 2), hang up

Actual results
"call ended" overlaps the phone number. See attached screenshot for details.
feature-b2g: --- → 2.2+
Priority: -- → P2
Assignee: nobody → thills
Whiteboard: [2.2-bug-bash] → [2.2-bug-bash][planned-sprint c=3]
Flags: in-moztrap+
Assignee

Comment 1

4 years ago
Posted image call-ended-rtl.png
Hi Stephany,

Can you take a look at this attachment and weigh in as to whether this looks ok from RTL perspective?  I adjusted things so there is room for the call ended string.

Basically, I'm asking about the part in red which happens when one of multiple calls hangs up.  The 'call ended' string was overlapping the contact previously.

Thanks,

-tamara
Flags: needinfo?(swilkes)

Comment 2

4 years ago
Thank you so much, Tamara. This looks good to me. Double checking with native speaker Ahmed as well.
Flags: needinfo?(swilkes) → needinfo?(nefzaoui)
Assignee

Updated

4 years ago
Status: NEW → ASSIGNED
Assignee

Comment 3

4 years ago
Hi Ahmed,

Any thoughts on this one?

Thanks,

-tamara
Assignee

Updated

4 years ago
Attachment #8563665 - Flags: review?(drs.bugzilla)

Comment 6

4 years ago
Flagging Kaze for review (comment #3) to spread the bug load a bit better.
Flags: needinfo?(nefzaoui) → needinfo?(fabien)
Comment on attachment 8563665 [details] [review]
[gaia] tamarahills:bugfix/1126374_Call_ended_overlap_rtl > mozilla-b2g:master

Please land when the RTL review is done, and you have fixed the one small problem that I called out in the PR.
Attachment #8563665 - Flags: review?(drs.bugzilla) → review+
Assignee

Comment 8

4 years ago
Hi Dylan,

Can you help move this one along?  We are still needing final RTL review from one of the native language speakers for some time now.

Thanks,

-tamara
Flags: needinfo?(doliver)
(In reply to Tamara Hills [:thills] from comment #3)
> Hi Ahmed,
> 
> Any thoughts on this one?
> 
> Thanks,
> 
> -tamara

My apologies for replying late to this
The screenshot from attachment 8557340 [details] looks OK to me :)
THanks!
Assignee

Comment 10

4 years ago
clearing NI not needed anymore.  Thanks Ahmed
Flags: needinfo?(fabien)
Flags: needinfo?(doliver)
Assignee

Comment 11

4 years ago
https://github.com/mozilla-b2g/gaia/commit/d4c3af78cd948f5965c2fa29a5fdfb5c00ae10ce

Try Run:  https://treeherder.mozilla.org/#/jobs?repo=gaia-try&revision=ab9f62a41a61

NI to myself to ask for uplift.
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Flags: needinfo?(thills)
Resolution: --- → FIXED
Assignee

Comment 12

4 years ago
Comment on attachment 8563665 [details] [review]
[gaia] tamarahills:bugfix/1126374_Call_ended_overlap_rtl > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): RTL feature
[User impact] if declined: User would have a UI with one string overlapping another in RTL
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): Relatively low and should be easy to backout.
[String changes made]: no
Flags: needinfo?(thills)
Attachment #8563665 - Flags: approval-gaia-v2.2?(release-mgmt)
Attachment #8563665 - Flags: approval-gaia-v2.2?(release-mgmt) → approval-gaia-v2.2+
This issue is verified fixed on Flame 3.0 master and on Flame 2.2.

No overlapping text following STR and caller name is truncated as demonstrated on comment 1.

Device: Flame 3.0 Master (full flash 319MB)
BuildID: 20150224010314
Gaia: 31ac1cd7a029d5e46dd7c92537b5c973c5d9826e
Gecko: 368c62292249
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Device: Flame 2.2 (full flash 319MB)
BuildID: 20150224002637
Gaia: 8e98fe665f3821d10d4d982cbb14cbe5b94d0be5
Gecko: 2b70d9d62799
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [rtl-impact] → [rtl-impact][QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [rtl-impact][QAnalyst-Triage?] → [rtl-impact][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.