Closed Bug 1126378 Opened 5 years ago Closed 5 years ago

[RTL] "ICE contacts" overlaps the arrow in the Emergency dialer

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect, P1)

x86_64
Linux
defect

Tracking

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S6 (20feb)
feature-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: jlorenzo, Assigned: autra)

References

Details

(Whiteboard: [2.2-bug-bash])

Attachments

(4 files)

Attached image Screenshot
Prerequisites
Have a passcode set on the device
Have an ICE contact set.

STR
1. Go to the emergency dialer

Actual result
Due to the RTL placement of the string the arrow now overlaps the string. See  attached screenshot.
Can we put this under the feature-b2g 2.2 flag?
blocking-b2g: --- → 2.2?
QA Whiteboard: [rtl-impact]
Flags: needinfo?(whuang)
blocking-b2g: 2.2? → ---
triage: P1 for confusing UI on the emergency dialer
feature-b2g: --- → 2.2+
Priority: -- → P1
Flags: needinfo?(whuang)
This is a chance to unify a bit more of the emergency and regular Dialers.
Target Milestone: --- → 2.2 S6 (20feb)
Flags: in-moztrap+
Assignee: nobody → augustin.trancart
Comment on attachment 8559254 [details] [review]
[PullReq] autra:bug-1126378 to mozilla-b2g:master

Hi Gabriel! 

Could you please review this patch? I hope you're the right person to r? :-)

Thanks!
Attachment #8559254 - Flags: review?(gsvelto)
Comment on attachment 8559254 [details] [review]
[PullReq] autra:bug-1126378 to mozilla-b2g:master

This is looking good but I'd like to see one little change: you've used an element with the `placeholder' class to hold the arrow and I'd rather see it with a self explanatory id instead. I've left the relevant comments on the bug. Ask for review again once you've updated the PR.
Attachment #8559254 - Flags: review?(gsvelto) → feedback+
Comment on attachment 8559254 [details] [review]
[PullReq] autra:bug-1126378 to mozilla-b2g:master

Thanks for the review! It is looking better this way :-)
Attachment #8559254 - Flags: review?(gsvelto)
Comment on attachment 8559254 [details] [review]
[PullReq] autra:bug-1126378 to mozilla-b2g:master

Excellent, thanks.
Attachment #8559254 - Flags: review?(gsvelto)
Attachment #8559254 - Flags: review+
Attachment #8559254 - Flags: feedback+
Thanks Augustin. Please land on master and request approval for 2.2.
Flags: needinfo?(augustin.trancart)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8559254 [details] [review]
[PullReq] autra:bug-1126378 to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bad layout for RTL
[User impact] if declined: In RTL language, user would see a broken UI
[Testing completed]: yes on flame 2.2
[Risk to taking this patch] (and alternatives if risky): moderate, only html and CSS change.
[String changes made]:none
Flags: needinfo?(augustin.trancart)
Attachment #8559254 - Flags: approval-gaia-v2.2?
Attachment #8559254 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Attached image Verify_RTL_ICE.png
This issue has been verified successfully on Flame 2.2.
Reproduce rate:0/5.
Attachment:Verify_RTL_ICE.png

Flame 2.2 build:

Build ID               20150214002504
Gaia Revision          ea64caf6d4ab03fc4472eca9f41f20d651d55fa9
Gaia Date              2015-02-13 05:27:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/6de30e6bbc84
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150214.044811
Firmware Date          Sat Feb 14 04:48:22 EST 2015
Bootloader             L1TC000118D0
QA Whiteboard: [rtl-impact] → [rtl-impact],[MGSEI-Triage+]
This issue has been verified successfully on Flame 3.0.
Attachment:Verify_3.0.png

Flame 3.0 build:

Build ID               20150215010209
Gaia Revision          f0b93e0668ef9565bd6f050b15b4f794d59feb65
Gaia Date              2015-02-13 13:13:27
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e0cb32a0b1aa
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150215.043133
Firmware Date          Sun Feb 15 04:31:43 EST 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
Attached image Verify_3.0.png
You need to log in before you can comment on or make changes to this bug.