[RTL] Contact's name is not RTL in ICE contacts

VERIFIED DUPLICATE of bug 1116803

Status

defect
VERIFIED DUPLICATE of bug 1116803
4 years ago
4 years ago

People

(Reporter: jlorenzo, Unassigned)

Tracking

unspecified
x86_64
Linux
Dependency tree / graph

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [2.2-bug-bash])

Attachments

(6 attachments)

Reporter

Description

4 years ago
Posted image Screenshot
Prerequisites
Have the phone set in Arabic
Have an ICE contact set

STR
1. Go to Contacts -> ICE contacts

Actual results
Contact's name is displayed from left to right. See screenshot.
Reporter

Comment 1

4 years ago
Is it possible to track this bug under the feature-b2g flag?
QA Whiteboard: [rtl-impact]
Flags: needinfo?(whuang)
Going to investigate this more deeply and see how bad it is.
Flags: needinfo?(lebedel.delphine)
Per p.16 in the RTL spec[1], the contact name is displayed in RTL form.
We should make it consistent.

[1] "https://bug906270.bugzilla.mozilla.org/attachment.cgi?id=8548340"
feature-b2g: --- → 2.2+
Flags: needinfo?(whuang)
This issue is fixed on today's 2.2 build
Gaia-Rev        d6141fa3208f224393269e17c39d1fe53b7e6a05
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/63b63054948d
Build-ID        20150130002501
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  39
FW-Date         Thu Oct 16 18:19:14 CST 2014
Bootloader      L1TC00011880

Closing as resolved WORKSFORME
And on 3.0 as well
Gaia-Rev        8238eeacc7030b2cdbf7ab4eba2f36779b702599
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/29b05d283b00
Build-ID        20150130010210
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  40
FW-Date         Tue Oct 21 15:59:42 CST 2014
Bootloader      L1TC10011880
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(lebedel.delphine)
Resolution: --- → WORKSFORME
Ugh. Didn't verify in the right place. Sorry for the noise :/
This in fact still occurs on 2.2 and 3.0

2.2:
Gaia-Rev        d6141fa3208f224393269e17c39d1fe53b7e6a05
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/63b63054948d
Build-ID        20150130002501
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  39
FW-Date         Thu Oct 16 18:19:14 CST 2014
Bootloader      L1TC00011880

3.0
Gaia-Rev        8238eeacc7030b2cdbf7ab4eba2f36779b702599
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/29b05d283b00
Build-ID        20150130010210
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  40
FW-Date         Tue Oct 21 15:59:42 CST 2014
Bootloader      L1TC10011880
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
For triage purposes: Bhavana asked last triage to investigate how bad this is by adding more ICE contacts. The fact is, you can't add more than 2 (see screenshot)
I agree this is inconsistent with the rest of the UI, but not 100% sure this should be a P1. Let's decide this at next triage
Since bug 1116803 has landed this is not longer the case.

Closing as worksforme
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → WORKSFORME
Reporter

Comment 10

4 years ago
Per comment 9 and its attachment.
Keywords: verifyme
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 1116803

Comment 11

4 years ago
    According Comment 9, clear the keyword. We have verified thsi issue again, and it is verified successfully on Flame 2.2/3.0.
Attachment:Verify_RTL.png
Flame 2.2 build:

Build ID               20150205002503
Gaia Revision          c2047a46e29696238e9b4c9caaba47736421449a
Gaia Date              2015-02-04 20:34:04
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/adfba0a07e9b
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150205.045043
Firmware Date          Thu Feb  5 04:50:54 EST 2015
Bootloader             L1TC000118D0

Flame 3.0 build:
Build ID               20150205010209
Gaia Revision          2b83a6d5d1185a438b5bbd287497ac2743b501db
Gaia Date              2015-02-04 21:30:59
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/34a66aaaca81
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150205.044014
Firmware Date          Thu Feb  5 04:40:24 EST 2015
Bootloader             L1TC000118D0
QA Whiteboard: [rtl-impact] → [rtl-impact],[MGSEI-Triage+]
Keywords: verifyme

Comment 12

4 years ago
Posted image Verify_RTL.png
According to comment 11 and my own verification on N5 2.2/master, this problem is fixed now.
Mark as VERIFIED DUPLICATE
See attachment: N5_master_verify1.png
Rate: 0/10

Device information:
N5 2.2 (pass)
Build ID               20150723002503
Gaia Revision          e1e6317f17a840b19af9dbb25f5a771d8d9fa161
Gaia Date              2015-07-15 21:05:11
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d8326043baec
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150723.042111
Firmware Date          Thu Jul 23 04:21:29 EDT 2015
Bootloader             HHZ12f

N5 master (pass)
Build ID               20150722010204
Gaia Revision          84c3bf622e211046d905803b34de5d331761f22d
Gaia Date              2015-07-21 16:28:35
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/8e5c888d0d89
Gecko Version          42.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150722.060727
Firmware Date          Wed Jul 22 06:07:44 EDT 2015
Bootloader             HHZ12f
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.