[RTL] Almost all the fields in new contact's page are left to right when you type with an LTR keyboard

VERIFIED FIXED in Firefox OS v2.2

Status

P1
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jlorenzo, Assigned: autra)

Tracking

unspecified
2.2 S6 (20feb)
x86_64
Linux

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [2.2-bug-bash])

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8555348 [details]
Screenshot

Pre-requisites
Set the language in Arabic

STR
1. Create a new contact
2. Input some text in every field

Actual result
All but the email field are displayed from left to right. See attached screenshot.
(Reporter)

Comment 1

4 years ago
Should we set this bug as a feature-b2g 2.2?
QA Whiteboard: [rtl-impact]
Flags: needinfo?(whuang)
feature-b2g: --- → 2.2+
Priority: -- → P1
Flags: needinfo?(whuang)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1116803
(Reporter)

Comment 3

4 years ago
verifyme to get a screenshot of the fix in 2.2. If 2.2 is okay, no need to verify 3.0.
Keywords: verifyme

Comment 4

4 years ago
Hi Johan, 
   I found it is still displayed from left to right(attachment:Verify_RTL_Flame3.0&2.2.png), but in Bug 1116803, the status is verifed. Could you confirm with it? Thanks.
Attachment:Verify_RTL_Flame3.0&2.2.png

Flame 3.0 build:

Build ID               20150209010211
Gaia Revision          0d7b35f23402c4cb29bca6b98280fec48a196dec
Gaia Date              2015-02-08 20:44:20
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/3436787a82d0
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150209.045655
Firmware Date          Mon Feb  9 04:57:06 EST 2015
Bootloader             L1TC000118D0

Flame 2.2 build:

Build ID               20150209162506
Gaia Revision          21cce750c095a3f815275fe5439fa9dbfe3dfc6b
Gaia Date              2015-02-09 21:57:53
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/41ccc5328740
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150209.194557
Firmware Date          Mon Feb  9 19:46:08 EST 2015
Bootloader             L1TC000118D0
Flags: needinfo?(jlorenzo)
Keywords: verifyme

Updated

4 years ago
QA Whiteboard: [rtl-impact] → [rtl-impact],[MGSEI-Triage+]
(Reporter)

Comment 5

4 years ago
Thanks for this verification Coler, let's reopen this bug then.
Status: RESOLVED → REOPENED
Flags: needinfo?(jlorenzo)
Resolution: DUPLICATE → ---
(Assignee)

Updated

4 years ago
Assignee: nobody → augustin.trancart
(Assignee)

Comment 6

4 years ago
Created attachment 8565353 [details]
screenshot-add-contact with gaia 2.2 2015-02-17

I cannot reproduce with latest gaia 2.2. The screenshot I attached shows a RTL interface. Is it possible to check this again? Thanks!!
Flags: needinfo?(jlorenzo)
(Assignee)

Comment 7

4 years ago
Oh you actually meant the input fields. Sorry :-)
Flags: needinfo?(jlorenzo)
(Assignee)

Comment 8

4 years ago
Actually, the css rule uses -moz-dir(ltr) in rtl context (see https://github.com/mozilla-b2g/gaia/pull/27328/files#diff-4874cd5f68db468c62f60073c52cfc14R574). So the fields are left-aligned only if you type in english in them. If you use a rtl keyboard like the arabic one, what you typed will be right-aligned (it is working on last 3.0).

This looks like a correct behaviour to me. We actually rely on the internal algorithm of -moz-dir. On the contrary, the email field should actually stay left-aligned, as it is always LTR right? So if you agree with that, I can fix the email field.
Flags: needinfo?(jlorenzo)
(Reporter)

Comment 9

4 years ago
Thanks for the clarification Augustin. We had a similar bug with this kind of question, we need to have every field RTL even with the English keyboard. See bug 1132559 comment 3 for details.
Flags: needinfo?(jlorenzo)
See Also: → bug 1132559
Summary: [RTL] Almost all the fields in new contact's page are left to right → [RTL] Almost all the fields in new contact's page are left to right when you type with an LTR keyboard
(Assignee)

Comment 11

4 years ago
Comment on attachment 8565412 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/28265

Hi Jose

Could you review this for me please? I worry a bit about this one, because it can affect all gaia.

Thanks!
Attachment #8565412 - Attachment description: [gaia] autra:bug-1126388 > mozilla-b2g:master → Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/28265
Attachment #8565412 - Flags: review?(jmcf)

Comment 12

4 years ago
Comment on attachment 8565412 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/28265

as this is a global change I would suggest you ask Wilson or other BB owner for a review 

thanks!
Attachment #8565412 - Flags: review?(jmcf)
(Assignee)

Comment 13

4 years ago
Comment on attachment 8565412 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/28265

Forwarding review to Wilson :-)
Attachment #8565412 - Flags: review?(wilsonpage)
Comment on attachment 8565412 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/28265

:nefzaoui originally wrote the rule which is being removed so it seems best that he review this change.
Attachment #8565412 - Flags: review?(wilsonpage) → review?(nefzaoui)
Comment on attachment 8565412 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/28265

LGTM.
Though gaia-try seems to be hanging for some reason
https://treeherder.mozilla.org/#/jobs?repo=gaia-try&revision=2cf3efc96f72
A rebase and push will retrigger it
Attachment #8565412 - Flags: review?(nefzaoui) → review+
(Assignee)

Comment 16

4 years ago
NI myself to checkin once the tests are green.
Flags: needinfo?(augustin.trancart)
(Assignee)

Updated

4 years ago
Flags: needinfo?(augustin.trancart)
Keywords: checkin-needed

Updated

4 years ago
Keywords: checkin-needed
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
merged in master: https://github.com/mozilla-b2g/gaia/commit/0886a0e
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 19

4 years ago
Comment on attachment 8565412 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/28265

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): not a regression
[User impact] if declined: low : only text field not right aligned if keyboard is ltr with a rtl global language.
[Testing completed]: on flame 2.2
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: none
Attachment #8565412 - Flags: approval-gaia-v2.2?(bbajaj)

Updated

4 years ago
Attachment #8565412 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/319c1b2a4b4b2a042106ae4eb3d4ea101ba8df6b
status-b2g-v2.2: affected → fixed
status-b2g-master: affected → fixed
Target Milestone: --- → 2.2 S6 (20feb)
This issue is verified fixed on the latest Nightly Flame 3.0 build.  This issue is not in the current Nightly 2.2 flame build, NI? myself to check it out on Monday.

Actual Results: All fields fill in RTL.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150220010206
Gaia: e4f7c67378e33e83f88d38ddb4a6c2cabf1423c3
Gecko: 1b4c5daa7b7a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150220002501
Gaia: ce79d35b92261e7cbfeaefebf87859ebeb0979b4
Gecko: b864abe1c6b3
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [rtl-impact],[MGSEI-Triage+] → [QAnalyst-Triage?][rtl-impact],[MGSEI-Triage+]
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
Flags: needinfo?(jmercado)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?][rtl-impact],[MGSEI-Triage+] → [QAnalyst-Triage+][rtl-impact],[MGSEI-Triage+]
Flags: needinfo?(ktucker)
This issue is also verified fixed on the latest Night 2.2 Flame build.

Actual Results: All fields fill in RTL.

Environmental Variables:
Device: Flame 2.2 KK (Full Flash) (319 MB)
BuildID: 20150223002503
Gaia: 389542b71c89253c0d176d3b0bfb54e275c19bf1
Gecko: 9fd3441c8983
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
status-b2g-v2.2: fixed → verified
Flags: needinfo?(jmercado) → needinfo?(ktucker)
Flags: needinfo?(ktucker)
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.