Lollipop build bustage: MP4Stream.h: No such file or directory

RESOLVED FIXED in mozilla38

Status

()

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: botond, Assigned: seinlin)

Tracking

Trunk
mozilla38
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 fixed, b2g-master fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Posted file Full error output
STR:
   1) Clone the B2G repo.
   2) ./config.sh nexus-5-l
   3) ./build.sh

This results in the following compiler error:

In file included from objdir-gecko/dom/media/mediasource/Unified_cpp_media_mediasource0.cpp:2:0:
gecko/dom/media/mediasource/ContainerParser.cpp:14:23: fatal error: MP4Stream.h: No such file or directory
 #include "MP4Stream.h"
                       ^

Full error output attached.

The offending include was added in bug 1102642.

I'm not sure what's causing the error, as MP4Stream.h is present in the EXPORTS of dom/media/fmp4/moz.build.
is it located in $MOZ_OBJDIR/dist/include/MP4Stream.h ?

did you re-run ./mach build ? (I'm not familiar with b2g build, and it builds fine on all B2G try runs)
Looks like dom/media/fmp4/moz.build is only processed when MOZ_FMP4 enabled [1], and current configure.in doesn't do that for Lollipop [2].
Unfortunately, MOZ_FMP4=1 trigger another error as below. Blake, could you please help check that?

In file included from Unified_cpp_dom_media_fmp4_gonk0.cpp:29:0:
../../../../../../gecko-dev/dom/media/fmp4/gonk/GonkVideoDecoderManager.cpp: In member function 'void mozilla::GonkVideoDecoderManager::codecReserved()':
../../../../../../gecko-dev/dom/media/fmp4/gonk/GonkVideoDecoderManager.cpp:494:42: error: 'class android::GonkNativeWindow' has no member named 'getBufferQueue'
     surface = new Surface(mNativeWindow->getBufferQueue());

[1] https://dxr.mozilla.org/mozilla-central/source/dom/media/moz.build?from=dom/media/moz.build#42
[2] https://dxr.mozilla.org/mozilla-central/source/configure.in#292
Flags: needinfo?(bwu)
I can make the entire code conditional on FMP4 being active.
Currently MOZ_FMP4 is not enabled yet on B2G L. 
See also bug 1112770.
Flags: needinfo?(bwu)
It looks MP4Stream.h is not exported in [1] due to [2] as comment 2. 
[1]https://dxr.mozilla.org/mozilla-central/source/dom/media/fmp4/moz.build#11
[2]https://dxr.mozilla.org/mozilla-central/source/dom/media/moz.build#42

jya, 
To cut this binding, is it possible to move MP4Stream to gecko/media/libstagefright/ which MP4_Demuxer locates as well?
Flags: needinfo?(jyavenard)
(Assignee)

Comment 6

4 years ago
Anthony and Matt, I think we can fix this compile issue as [1]. Could you review this patch? Thanks!

[1] https://dxr.mozilla.org/mozilla-central/source/dom/media/eme/MediaKeys.cpp#21
Attachment #8556312 - Flags: review?(matt.woodrow)
Attachment #8556312 - Flags: review?(ajones)
I hadn't seen this one was done already, so I wrapped something and it's exactly my solution. so r+ for me :)
Flags: needinfo?(jyavenard)
(Assignee)

Comment 8

4 years ago
Comment on attachment 8556312 [details] [diff] [review]
bug-1126499.patch

Per comment 7.
Attachment #8556312 - Flags: review?(matt.woodrow)
Attachment #8556312 - Flags: review?(ajones)
Attachment #8556312 - Flags: review+
(Assignee)

Updated

4 years ago
blocking-b2g: --- → 2.2?
(Assignee)

Comment 10

4 years ago
Comment on attachment 8556312 [details] [diff] [review]
bug-1126499.patch

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): compile error
User impact if declined: compile failed
Testing completed: verify on m/c and try server
Risk to taking this patch (and alternatives if risky): low, only add compile flag for mp4 source code.
String or UUID changes made by this patch: none
Attachment #8556312 - Flags: approval-mozilla-b2g37?

Updated

4 years ago
blocking-b2g: 2.2? → 2.2+
https://hg.mozilla.org/mozilla-central/rev/f64e404de9d9
Assignee: nobody → kli
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1126519
Attachment #8556312 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
You need to log in before you can comment on or make changes to this bug.