Closed Bug 1126566 Opened 8 years ago Closed 8 years ago

[email] Account settings layout regression

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(b2g-v2.1 unaffected, b2g-v2.2 fixed, b2g-master fixed)

VERIFIED FIXED
2.2 S5 (6feb)
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: tchevalier, Assigned: jrburke)

Details

(Keywords: regression, Whiteboard: [2.2-bug-bash])

Attachments

(2 files, 1 obsolete file)

Attached image Issue (obsolete) —
Layout on Email account settings has regressed since 2.1. Labels now have less room, and label for synchronization is even truncated. Not sure if it was able to go on two lines before, but as you can see on the screenshot the end of the string is now missing in French.

The same screen while creating a new account is also affected.
Attached image Issue
Attachment #8555539 - Attachment is obsolete: true
We probably want a regression-window here, I'll let the devs decide if it's needed.
Keywords: regression
Attached file GitHub pull request
This is a regression caused by the RTL changes in the changeset mentioned in bug 1064617 comment 11, so affects 2.2+ only.

The attached pull request fixes the issues. Thanks for catching this, sorry it slipped through on the first pass RTL changes. See the pull request to see screenshots that show how the French locale looks with the changes.
Assignee: nobody → jrburke
Status: NEW → ASSIGNED
Attachment #8555654 - Flags: review?(bugmail)
Comment on attachment 8555654 [details] [review]
GitHub pull request

Thanks for the elaborating comment in the CSS and the pretty pics (:tchevalier too!)
Attachment #8555654 - Flags: review?(bugmail) → review+
Merged in master:
https://github.com/mozilla-b2g/gaia/commit/3e5156c5cc1db13cb9d38521a148ea62a0fd6ecb

from pull request:
https://github.com/mozilla-b2g/gaia/pull/27729
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Comment on attachment 8555654 [details] [review]
GitHub pull request

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Changeset in bug 1064617 comment 11 for initial RTL support. Since that change is already on 2.2, this change should be too.

[User impact] if declined:
Worse l10n experience, layout not as compact, some text cut off.

[Testing completed]:
Tested on flame device with French, and a RTL locale, along with English.

[Risk to taking this patch] (and alternatives if risky):
Very low, just some CSS tweaks and a class change for a few HTML elements.

[String changes made]:
none
Attachment #8555654 - Flags: approval-gaia-v2.2?
Attachment #8555654 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Verified fixed on latest master, thanks a bunch for fixing this so quickly!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.