Closed Bug 1126613 Opened 5 years ago Closed 5 years ago

RTL, SHB, Utility tray overlapping SHB

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

x86
macOS
defect
Not set

Tracking

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S6 (20feb)
feature-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: gwagner, Assigned: mikehenrty)

References

Details

(Whiteboard: [systemsfe])

User Story

STR:

1.) Enable software home button.
2.) Switch to RTL language.
3.) Open browser and flip phone to landscape orientation.
4.) Pull down utility tray.

Expected result:
Utility tray does not overlap SHB.

Actual restult:
Utility tray overlaps SHB, and leaves a gap on the other side of the screen. (see screenshot)

Attachments

(4 files)

Attached image 2015-01-27-16-53-44.png
No description provided.
Whiteboard: [systemsfe]
Where should the SHB be in a RTL scenario?
Flags: needinfo?(firefoxos-ux-bugzilla)
blocking-b2g: --- → 2.2?
blocking-b2g: 2.2? → ---
feature-b2g: --- → 2.2+
Assignee: nobody → gmarty
Gregor, is the question here about what's expected in landscape mode, and then what is expected in RTL landscape mode? It's hard to tell from the screenshot (which is not in Arabic)? Thanks!
Flags: needinfo?(anygregor)
(In reply to Stephany Wilkes from comment #2)
> Gregor, is the question here about what's expected in landscape mode, and
> then what is expected in RTL landscape mode? It's hard to tell from the
> screenshot (which is not in Arabic)? Thanks!

The SHB is always on the right side when you change to landscape mode. So the question is if the SHB should be on the left side when in RTL mode.
Flags: needinfo?(anygregor) → needinfo?(swilkes)
Attached image 2015-01-07-02-52-54.png
I can't reproduce the issue as shown in the original screenshot. I turned the soft home button on and put the phone into Arabic on 2.2. Here is a screenshot of what I see.
Flags: needinfo?(swilkes)
Flags: needinfo?(firefoxos-ux-bugzilla)
(In reply to Stephany Wilkes from comment #4)
> Created attachment 8559975 [details]
> 2015-01-07-02-52-54.png
> 
> I can't reproduce the issue as shown in the original screenshot. I turned
> the soft home button on and put the phone into Arabic on 2.2. Here is a
> screenshot of what I see.

You are seeing the issue :) The overlay is overlapping the SHB. This shouldn't be the case.
User Story: (updated)
Ha Gregor! :)

I'll add this to the bidi pattern, but I'd expect that the location and behavior of the SHB should not change in RTL. It should remain the same as in LTR languages, in both landscape and portrait modes.
Flags: needinfo?(rmacdonald)
Flags: needinfo?(rmacdonald)
Stealing this one too.
Assignee: gmarty → mhenretty
Comment on attachment 8560763 [details] [review]
[PullReq] mikehenrty:bug-1126613-utility-tray-rtl to mozilla-b2g:master

Easy one.
Attachment #8560763 - Flags: review?(alive)
Target Milestone: --- → 2.2 S6 (20feb)
Comment on attachment 8560763 [details] [review]
[PullReq] mikehenrty:bug-1126613-utility-tray-rtl to mozilla-b2g:master

\O/
Attachment #8560763 - Flags: review?(alive) → review+
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
This issue is verified fixed on Flame Master.

Result: When the device is set in RTL mode, the utility tray does not overlap with SHB on an landscape-enabled app, such as Browser, Gallery, and Video.
 
Device: Flame Master (319mb, full flash)
Build ID: 20150210010523
Gaia: 0cf517083f7eb5fc269e1236edba50534f65e3cd
Gecko: 2cb22c058add
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
------------------------------
Leaving verifyme for 2.2 verification
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Hi Michael,
This issue still exists on latest build of Flame 2.2 by STR in comment 0. Could you please help to confirm whether this issue will uplift to 2.2 build or not? Many thanks :)
Flags: needinfo?(mhenretty)
I never requested uplift!
Flags: needinfo?(mhenretty)
Comment on attachment 8560763 [details] [review]
[PullReq] mikehenrty:bug-1126613-utility-tray-rtl to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Maybe not a regression.

[User impact] if declined:
RTL utility tray looks terrible with SHB.


[Testing completed]:
CSS change only, so manually tested.

[Risk to taking this patch] (and alternatives if risky):
Low risk, 1 line of css that affects RTL is the only change.

[String changes made]: none.
Attachment #8560763 - Flags: approval-gaia-v2.2?
Attachment #8560763 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This Problem is verified as "pass" on latest build of Flame2.2 by the STR in comment 0.
Actual result: The utility tray does not overlap with SHB on an landscape-enabled app, such as Browser, Gallery, and Video.
See attachment: Verify_Pass_Flame2.2.png
Rate: 0/10

Device information:
Flame 2.2:(Pass)
Build ID               20150628002505
Gaia Revision          0179935627012dfde3ca036c9a71035be463b7ad
Gaia Date              2015-06-26 21:13:44
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/35e09270da3a
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150628.035537
Firmware Date          Sun Jun 28 03:55:48 EDT 2015
Bootloader             L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.