Closed Bug 1126685 Opened 7 years ago Closed 7 years ago

[UITest] bluetooth does not listen to the right event in v2

Categories

(Firefox OS Graveyard :: Gaia::Bluetooth, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: gasolin, Assigned: gasolin)

Details

Attachments

(1 file)

According to 
https://github.com/mozilla-B2G/gaia/blob/master/dev_apps/uitest/js/HW/bluetooth.js#L57

The mozBluetooth enable/disable event are replaced to listen 'adapter attribute changed'.

Or do it via enable()/disable().then callback
Assignee: nobody → gasolin
Status: NEW → ASSIGNED
Comment on attachment 8556360 [details] [review]
[PullReq] gasolin:issue-1126685 to mozilla-b2g:master

The root cause is uidemos app does not listen to the right adapter.attributechange to get proper stat and address.


The btHelper.getAddress can not guarantee it could get address in APIv2 unless we turn it into promise based api.

Since it's not widely used in other gaia app, as discussed, we will not support getAddress in v2.
Attachment #8556360 - Flags: review?(iliu)
Test passed on flame.
1. open uidemos>HW>BT, turn on/off, the stat/address shows correctly
2. open settings and uidemos, turn BT on in settings then swipe into uidemos, the stat/address shows correctly
Comment on attachment 8556360 [details] [review]
[PullReq] gasolin:issue-1126685 to mozilla-b2g:master

r+ with me! Well done.
Attachment #8556360 - Flags: review?(iliu) → review+
thanks!
Keywords: checkin-needed
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
Component: Gaia → Gaia::Bluetooth File Transfer
Keywords: checkin-needed
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
hacking the autobot again ;)
Keywords: checkin-needed
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
merged to master https://github.com/mozilla-b2g/gaia/commit/55f192211656ecbb5a0b908843d02d178c58b1d0

thanks!
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.