[RTL][System] The settings icon is right-aligned when oauth iframe displays net error.

VERIFIED FIXED in 2.2 S6 (20feb)

Status

defect
P3
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: lulu.tian, Assigned: mmedeiros)

Tracking

unspecified
2.2 S6 (20feb)
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
[1.Description]:
[RTL][Calendar]The settings icon is not shown at left of screen when you log in a Google account in Calendar with no data and wifi connected.
See attachment:settingsicon.png

[2.Testing Steps]: 
Prerequisite: The device has no data and Wi-Fi network connected.
1. Launch Calendar.
2. Tap the drawer button.
3. Tap the settings icon.
4. Select Add Account -> Google.

[3.Expected Result]: 
4. The settings icon should display at left side of screen.

[4.Actual Result]: 
4. The settings icon is shown at right side of screen.

[5.Reproduction build]: 
Flame 2.2 build:
Gaia-Rev        80d5b797fd0497a7e3337b7798a21b2e1219681a
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/01bf1516a65b
Build-ID        20150127002504
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150127.035842
FW-Date         Tue Jan 27 03:58:52 EST 2015
Bootloader      L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

4 years ago
Posted image settingsicon.png
(Reporter)

Updated

4 years ago
QA Whiteboard: [rtl-impact]
Priority: -- → P3
(Assignee)

Updated

4 years ago
Assignee: nobody → mmedeiros

Updated

4 years ago
Flags: in-moztrap-
(Assignee)

Comment 2

4 years ago
this is not calendars fault, the behavior should be the same for any iframe that displays the net_error message. I'll provide a patch in a few minutes.
Component: Gaia::Calendar → Gaia::System
Summary: [RTL][Calendar]The settings icon is right-aligned on the login page when this page displays error. → [RTL][System] The settings icon is right-aligned when oauth iframe displays net error.
(Assignee)

Updated

4 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → 2.2 S6 (20feb)
(Assignee)

Updated

4 years ago
Attachment #8561879 - Flags: review?(bfrancis)
Comment on attachment 8561879 [details] [review]
[PullReq] millermedeiros:1126713-rtl-settings-icon-login to mozilla-b2g:master

Thanks
Attachment #8561879 - Flags: review?(bfrancis) → review+
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
(Assignee)

Updated

4 years ago
Component: Gaia::System → Gaia::Browser
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/28097

The pull request could not be applied to the integration branch. Please try again after current integration is complete. You may need to rebase your branch against the target branch.
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Comment 8

4 years ago
This issue has been verified on Flame 3.0.
Attachment:Verify_RTL_Calendar.png.

Flame 3.0 build:

Gaia-Rev        e280a660955bbdab265d50f8d9e009de34082332
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/650863f6987b
Build-ID        20150211160231
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150211.192431
FW-Date         Wed Feb 11 19:24:42 EST 2015
Bootloader      L1TC000118D0

Comment 9

4 years ago
Comment on attachment 8561879 [details] [review]
[PullReq] millermedeiros:1126713-rtl-settings-icon-login to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): none
[User impact] if declined: icon will display at the wrong side of the screen (not following the RTL UX specs)
[Testing completed]: manual
[Risk to taking this patch] (and alternatives if risky): very low risk
[String changes made]: none
Attachment #8561879 - Flags: approval-gaia-v2.2?
this blocks calendar-rtl so it should be considered a blocker
blocking-b2g: --- → 2.2?
blocking-b2g: 2.2? → 2.2+
Attachment #8561879 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Verified fixed on Flame 3.0 

Settings icon on iframe when net error appears is left aligned when language is RTL. Checked on add Google account in Calendar app with no data connection.

needinfo-ing self and adding verifyme tag to test on tomorrow's nightly Flame 2.2

Device: Flame 3.0
Build ID: 20150224010314
Gaia: 31ac1cd7a029d5e46dd7c92537b5c973c5d9826e
Gecko: 368c62292249
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [rtl-impact] → [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
Flags: needinfo?(bzumwalt)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
Issue verified fixed on Flame 2.2 Nightly

Settings icon on iframe when net error appears is left aligned when language is RTL. Checked on add Google account in Calendar app with no data connection.

Device: Flame 2.2
Build ID: 20150225002505
Gaia: ca64f2fe145909f31af266b1730874051ba76c78
Gecko: 16804008c29f
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(bzumwalt) → needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15878/
Flags: in-moztrap- → in-moztrap+
You need to log in before you can comment on or make changes to this bug.