Investigate test_browser_save_image failure

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
9 months ago

People

(Reporter: RobertC, Unassigned, NeedInfo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
test_browser_save_image is failing intermittently with what looks to be a javascript/marionette issue

Most recent errors/exceptions are:
01-28 15:32:52.844 W/GeckoConsole(23734): [JavaScript Error: "NS_ERROR_NOT_INITIALIZED: Component returned failure code: 0xc1f30001 (NS_ERROR_NOT_INITIALIZED) [nsIMessageSender.sendAsyncMessage]" {file: "chrome://specialpowers/content/SpecialPowersObserver.js" line: 103}]01-28 15:32:52.844 W/GeckoConsole(23734): [JavaScript Error: "NS_ERROR_NOT_INITIALIZED: Component returned failure code: 0xc1f30001 (NS_ERROR_NOT_INITIALIZED) [nsIMessageSender.sendAsyncMessage]" {file: "chrome://specialpowers/content/SpecialPowersObserver.js" line: 103}]01-28 15:32:53.914 W/GeckoConsole(23734): [JavaScript Error: "NS_ERROR_NOT_INITIALIZED: Component returned failure code: 0xc1f30001 (NS_ERROR_NOT_INITIALIZED) [nsIMessageSender.sendAsyncMessage]" {file: "chrome://specialpowers/content/SpecialPowersObserver.js" line: 103}]01-28 15:32:53.914 W/GeckoConsole(23734): [JavaScript Error: "NS_ERROR_NOT_INITIALIZED: Component returned failure code: 0xc1f30001 (NS_ERROR_NOT_INITIALIZED) [nsIMessageSender.sendAsyncMessage]" {file: "chrome://specialpowers/content/SpecialPowersObserver.js" line: 103}]01-28 15:32:53.914 W/GeckoConsole(23734): [JavaScript Error: "NS_ERROR_NOT_INITIALIZED: Component returned failure code: 0xc1f30001 (NS_ERROR_NOT_INITIALIZED) [nsIMessageSender.sendAsyncMessage]" {file: "chrome://specialpowers/content/SpecialPowersObserver.js" line: 103}]
The B2G process has restarted after crashing during  the tests so Marionette can't respond due to either a Gecko, Gaia or Marionette error. Above, the 5 most recent errors are listed. Check logcat for all errors if these errors are not the cause of the failure.
TEST-UNEXPECTED-ERROR | test_browser_save_image.py TestBrowserSaveImage.test_browser_save_image | TimeoutException: TimeoutException: Connection timed out


Traceback (most recent call last):
  File "/home/robertchira/.virtualenvs/gaia/local/lib/python2.7/site-packages/marionette_client-0.8.7-py2.7.egg/marionette/marionette_test.py", line 283, in run
    testMethod()
  File "/home/robertchira/workspace/gaia/tests/python/gaia-ui-tests/gaiatest/tests/functional/browser/test_browser_save_image.py", line 35, in test_browser_save_image
    browser = search.go_to_url(self.test_url)
  File "/home/robertchira/workspace/gaia/tests/python/gaia-ui-tests/gaiatest/apps/search/app.py", line 34, in go_to_url
    return search_panel.go_to_url(url)
  File "/home/robertchira/workspace/gaia/tests/python/gaia-ui-tests/gaiatest/apps/homescreen/regions/search_panel.py", line 66, in go_to_url
    self.keyboard.tap_enter()
  File "/home/robertchira/workspace/gaia/tests/python/gaia-ui-tests/gaiatest/apps/keyboard/app.py", line 325, in tap_enter
    self.apps.switch_to_displayed_app()
  File "/home/robertchira/workspace/gaia/tests/python/gaia-ui-tests/gaiatest/gaia_test.py", line 98, in switch_to_displayed_app
    self.marionette.switch_to_frame(self.displayed_app.frame)
  File "/home/robertchira/.virtualenvs/gaia/local/lib/python2.7/site-packages/marionette_client-0.8.7-py2.7.egg/marionette/marionette.py", line 1074, in switch_to_frame
    response = self._send_message('switchToFrame', 'ok', element=frame.id, focus=focus)
  File "/home/robertchira/.virtualenvs/gaia/local/lib/python2.7/site-packages/marionette_client-0.8.7-py2.7.egg/marionette/decorators.py", line 36, in _
    return func(*args, **kwargs)
  File "/home/robertchira/.virtualenvs/gaia/local/lib/python2.7/site-packages/marionette_client-0.8.7-py2.7.egg/marionette/marionette.py", line 615, in _send_message
    "Connection timed out", status=errors.ErrorCodes.TIMEOUT)
TEST-INFO took 474523ms

The issue is not reproduced manually and with automation I got a repro rate of 1 out of 10.

Build info flame KK 319MB v3.0 v188-1:
Gaia-Rev        1d53fb07984298253aad64bfa4236b7167ee3d4d
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/b2b10231606b
Build-ID        20150128010234
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150128.043233
FW-Date         Wed Jan 28 04:32:44 EST 2015
Bootloader      L1TC10011880
(Reporter)

Updated

4 years ago
QA Whiteboard: [fxosqa-auto-s9+]
(Reporter)

Comment 1

4 years ago
Created attachment 8555839 [details]
logcat.txt

Logcat of the test failing locally.
(Reporter)

Comment 2

4 years ago
I have not seen tests failing with this error recently. I tried running the test again locally, but was not able to reproduce it. Ran the test 40 times.

Adhoc run: http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk.ui.adhoc/691/console

I recommend leaving this bug open for a couple of week and if there are no more failures it can be closed.
(Reporter)

Updated

4 years ago
Assignee: robert.chira → nobody
(Reporter)

Updated

4 years ago
QA Whiteboard: [fxosqa-auto-s9+] → [fxosqa-auto-dropped-s9] [fxosqa-auto-backlog+]
(Reporter)

Comment 3

4 years ago
ni Geo to check if this issue reappears in the next couple of weeks.
Flags: needinfo?(gmealer)

Comment 4

9 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.