[RTL] USSD input displays from left to right

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Dialer
P2
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: jlorenzo, Assigned: gsvelto)

Tracking

unspecified
2.2 S5 (6feb)
x86_64
Linux

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(3 attachments)

Created attachment 8555905 [details]
Screenshot

STR
1. Open the USSD interface (for instance with Orange France carrier, call #123#)
2. Type some letters in the input

Actual result
The input is from left to right. See attached screenshot.
Can we nominate this bug for RTL triage, Dylan?
Blocks: 1071918
QA Whiteboard: [rtl-impact]
Flags: needinfo?(doliver)
Target Milestone: --- → 2.2 S6 (20feb)
(Assignee)

Comment 2

3 years ago
I just did a quick check and removing the dir="auto" attribute from the response input text field is enough to fix this. I'll post a patch shortly.
Created attachment 8555914 [details] [review]
[PullReq] gabrielesvelto:bug-1126845-mmi-response-rtl to mozilla-b2g:master
(Assignee)

Comment 4

3 years ago
Comment on attachment 8555914 [details] [review]
[PullReq] gabrielesvelto:bug-1126845-mmi-response-rtl to mozilla-b2g:master

BTW, trying out autolander since it's becoming "The One True Way" to land stuff on gaia.
Attachment #8555914 - Flags: review?(drs.bugzilla)
Attachment #8555914 - Flags: review?(drs.bugzilla) → review+
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/27752

The pull request could not be applied to the integration branch. Please try again after current integration is complete.
feature-b2g: --- → 2.2+
Flags: needinfo?(doliver)
Priority: -- → P2
(Assignee)

Comment 6

3 years ago
(In reply to Autolander from comment #5)
> The pull request could not be applied to the integration branch. Please try
> again after current integration is complete.

Meh.
Assignee: nobody → gsvelto
Status: NEW → ASSIGNED
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/27752

The pull request could not be applied to the integration branch. Please try again after current integration is complete.
(Assignee)

Comment 8

3 years ago
Green try run: https://treeherder.mozilla.org/ui/#/jobs?repo=gaia-try&revision=72d6f4955c29

Merged manually to gaia/master

https://github.com/mozilla-b2g/gaia/commit/3462f0d6b59a81e286c4a1bf93a87517dd6a834b
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

3 years ago
Comment on attachment 8555914 [details] [review]
[PullReq] gabrielesvelto:bug-1126845-mmi-response-rtl to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): -
[User impact] if declined: The MMI response input field is show in LTR mode when using an RTL locale
[Testing completed]: Tested the patch on a device using the Arabic locale
[Risk to taking this patch] (and alternatives if risky): Practically none, this is a single-line change
[String changes made]: None
Attachment #8555914 - Flags: approval-gaia-v2.2?(release-mgmt)

Updated

3 years ago
Attachment #8555914 - Flags: approval-gaia-v2.2?(release-mgmt) → approval-gaia-v2.2+
(Assignee)

Updated

3 years ago
status-b2g-master: affected → fixed
v2.2: https://github.com/mozilla-b2g/gaia/commit/7e9102059d141423027382d7aaae2ba475d72b28
status-b2g-v2.2: affected → fixed
Target Milestone: 2.2 S6 (20feb) → 2.2 S5 (6feb)

Comment 11

3 years ago
Created attachment 8560331 [details]
Verify_RTL.png

Comment 12

3 years ago
This issue has been verified successfully on Flame 2.2/3.0
Reproduce rate:0/5
Attachments:Verify_RTL.png

Flame 2.2 build:

Build ID               20150205002503
Gaia Revision          c2047a46e29696238e9b4c9caaba47736421449a
Gaia Date              2015-02-04 20:34:04
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/adfba0a07e9b
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150205.045043
Firmware Date          Thu Feb  5 04:50:54 EST 2015
Bootloader             L1TC000118D0

Flame 3.0 build:

Build ID               20150205010209
Gaia Revision          2b83a6d5d1185a438b5bbd287497ac2743b501db
Gaia Date              2015-02-04 21:30:59
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/34a66aaaca81
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150205.044014
Firmware Date          Thu Feb  5 04:40:24 EST 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [rtl-impact] → [rtl-impact],[MGSEI-Triage+]
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/155529/
You need to log in before you can comment on or make changes to this bug.