[RTL] LTR names are truncated at the beginning when importing contacts from Gmail

RESOLVED DUPLICATE of bug 1126587

Status

defect
P2
normal
RESOLVED DUPLICATE of bug 1126587
4 years ago
4 years ago

People

(Reporter: jlorenzo, Unassigned)

Tracking

unspecified
x86_64
Linux
Dependency tree / graph

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 affected, b2g-master affected)

Details

Attachments

(2 attachments)

Reporter

Description

4 years ago
Posted image LTR/RTL comparison
Similar to bug 1126883.

Prerequisites:
Have a Gmail contact with a long enough name (more than 20 characters).

STR
1. Go to import contacts from Gmail
2. Scroll down to your contact

Expected result
I don't know what's the right behavior, but as it's a latin name, I would expect it to be cropped at the end of the last name.

Actual results
Currently, the first name is cropped, which is annoying especially if you sorted your contacts by first name. See LTR/RTL comparison for details.
Reporter

Comment 1

4 years ago
Ahmed, do you think the current implementation in Arabic is correct?
Flags: needinfo?(nefzaoui)
feature-b2g: --- → 2.2+
Priority: -- → P2
Can we have a better understanding of how we should display names here?
Posted file bdi_names.html
I guess this would explain exactly what's the need of this bug.
Flags: needinfo?(nefzaoui)

Comment 4

4 years ago
Flagging Francisco to see if we can get someone assigned to take this P2 ahead of FL on Monday.
Flags: needinfo?(francisco)
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(francisco)
Resolution: --- → DUPLICATE
Duplicate of bug: 1126587
You need to log in before you can comment on or make changes to this bug.