Closed Bug 1126941 Opened 7 years ago Closed 7 years ago

Update pdf.js to version 1.0.1130

Categories

(Firefox :: PDF Viewer, task)

task
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 38

People

(Reporter: RyanVM, Assigned: RyanVM)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

+++ This bug was initially created as a clone of Bug #1117757 +++

Changes since last update:
#5552 Creates/refactors PDFPageView class
#5603 Use Content-Range instead of Content-Length #5512
#5618 Version 1.0.1040
#5606 Add a |textlayerrendered| event
#5600 Implement guards for stringToBytes and bytesToString
#5622 Move the |pagerendered| event to pdf_page_view.js
#5554 Refactors getDocument and adds PDFDataRangeTransport.
#5632 Fixes B2G file open sequence.
#5627 Whitelists 'tel' schema.
#5631 Refactor searching for end of inline (EI) JPEG image streams
#5624 Base64 example and be more flexible what type of data is passed
#5638 Fix thumbnail scaling regression for files with different page sizes (issue 5637)
#5641 Prevent setting |isStandardFont| to |undefined| for non-embedded fonts
#5639 Attempt to display the File size quicker in the Document Properties dialog (PR 5554 followup)
#5646 Amend the docs for |disableAutoFetch| to mention that streaming must also be disabled
#5619 Chrome extension: Add options page
#5567 Add marker segment (PLT, PLM) and refactor TLM
#5659 Fix thumbnail rendering regression, when using |draw|, for PDF files with blend modes (issue 5637)
#5660 Fill temporary canvases with a white background too
#5511 Bug 639134 - update check for document colors
#5610 Better thumbnail image scaling
#5596 Fix border sizes around thumbnails
#5588 Remove unused anchor links placed before every page
#5671 Remove unused index.html.template
#5674 Avoid getting |childNodes| twice in PDFPageView_reset, by using the variable instead
#5672 Remove unused viewer-snippet-b2g-activity-header.html
#5675 Remove obselete file from .gitignore
#5669 Avoid out of range array access in JBIG2 decoder
#5673 Refactor the thumbnail code
#5679 Refactor the outline code
With the usual review split :)

https://treeherder.mozilla.org/#/jobs?repo=try&revision=24fd21152f30
Attachment #8555993 - Flags: review?(dtownsend)
Attachment #8555993 - Flags: review?(bdahl)
Attachment #8555993 - Flags: review?(dtownsend) → review+
Comment on attachment 8555993 [details] [diff] [review]
Update pdf.js to version 1.0.1123

For whoever gets to it first.
Attachment #8555993 - Flags: review?(ydelendik)
Might as well sync with upstream while we wait.

Changes since last update:
#5678 Refactor the attachment code
Summary: Update pdf.js to version 1.0.1123 → Update pdf.js to version 1.0.1130
Attachment #8555993 - Attachment is obsolete: true
Attachment #8555993 - Flags: review?(ydelendik)
Attachment #8555993 - Flags: review?(bdahl)
Attachment #8557133 - Flags: review?(ydelendik)
Attachment #8557133 - Flags: review?(bdahl)
Comment on attachment 8557133 [details] [diff] [review]
Update pdf.js to version 1.0.1130

Review of attachment 8557133 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good
Attachment #8557133 - Flags: review?(ydelendik)
Attachment #8557133 - Flags: review?(bdahl)
Attachment #8557133 - Flags: review+
Thanks :)
https://hg.mozilla.org/integration/fx-team/rev/9289992e25eb
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/9289992e25eb
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 38
Blocks: 1135021
No longer blocks: 1135021
Type: defect → task
No longer depends on: 1117757
You need to log in before you can comment on or make changes to this bug.