CSS animation causes images to only load partially

RESOLVED DUPLICATE of bug 1098958

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1098958
3 years ago
3 years ago

People

(Reporter: gargaj, Unassigned)

Tracking

({css3})

35 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150122214805

Steps to reproduce:

The issue is reproducible by visiting
https://dl.dropboxusercontent.com/u/3417034/firefox-css-animation-bug/onlinetest.html
https://dl.dropboxusercontent.com/u/3417034/firefox-css-animation-bug/onlinetest2.html

The page contains two or more images, both animated (translation and rotation) via CSS3 animations.


Actual results:

http://pasteboard.co/HAsUdvf.png - the images (inconsistently) fail to load fully. In some cases, a low-resolution pixelated version is visible instead of the finer version.


Expected results:

The images should've loaded fully: http://pasteboard.co/HAFYOew.png

- The issue doesn't happen if the page is loaded locally, only through network.
- The issue doesn't happen if the image is converted to lower resolution or to JPG.
- The issue immediately disappears if the CSS animation is disabled, even if it's done via Firebug.
- The images themselves are fully visible when viewed through View Image.

The issue happens on:
- FF 34.0, 35.0 and 35.0.1
- XP, Win7, Win8.1, OSX
- Both hardware acceleration enabled or disabled
- NVIDIA, AMD and Intel GPUs
(Reporter)

Updated

3 years ago
(Reporter)

Comment 1

3 years ago
Additional observation: the issue rarely occurs when the page is FIRST loaded, however it almost always happens on a reload.
Keywords: css3
(Reporter)

Comment 2

3 years ago
...on a shift-Reload, I mean.

Comment 3

3 years ago
This seemd to be fixed by Bug 1098958.
Could you test with latest Beta36[1], Dev37.0a2[2] and Nightly38.a2[3]?

[1] https://www.mozilla.org/en-US/firefox/channel/#beta
[2] https://www.mozilla.org/en-US/firefox/channel/#developer
[3] https://nightly.mozilla.org/
Flags: needinfo?(gargaj)
(Reporter)

Comment 4

3 years ago
Fixed in 36.0
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(gargaj)
Resolution: --- → DUPLICATE
Duplicate of bug: 1098958
You need to log in before you can comment on or make changes to this bug.