Not able to end an ongoing call

RESOLVED DUPLICATE of bug 1127113

Status

Firefox OS
Gaia::Dialer
RESOLVED DUPLICATE of bug 1127113
3 years ago
3 years ago

People

(Reporter: Anshul, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 ?)

Details

(Whiteboard: [caf priority: p2][CR 784382])

Attachments

(1 attachment)

454.56 KB, text/plain
Details
(Reporter)

Description

3 years ago
STR
 - Power cycle the device and camp on the network
 - Make a mobile originated call and answer the call on the other end
 - End the call using end bottom

Expected result: Call should end after tapping on the end call button
Actual result: Not able to end the call after tapping on end call button
(Reporter)

Updated

3 years ago
Whiteboard: [caf priority: p2][CR 784382]
(Reporter)

Comment 1

3 years ago
Please find the log attached. I see the following exception in the logs that may be the reason for the failure to end the call.

01-28 15:46:42.167 W/GeckoConsole(  270): [JavaScript Error: "NS_ERROR_FAILURE: " {file: "app://callscreen.gaiamobile.org/gaia_build_defer_index.js" line: 258}]
(Reporter)

Comment 2

3 years ago
Created attachment 8556169 [details]
android logs
(Reporter)

Updated

3 years ago
See Also: → bug 1127113
Needinfo Doug to investigate. 
Please call out if more information you need.
Flags: needinfo?(drs.bugzilla)
Per the blocking flag and the metabug, I assume 2.2 is impacted. I am not able to reproduce on our last 2.2 internal build[1]. Anshul, would you mind giving more details about the build you tested? 

[1] Gaia-Rev        46b590648007d51a0406b21b1d6f98eba8e3898e
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/b03afde7e699
Build-ID        20150128162504
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150128.201416
FW-Date         Wed Jan 28 20:14:27 EST 2015
Bootloader      L1TC000118D0
blocking-b2g: 2.2? → ---
status-b2g-v2.2: --- → ?
Flags: needinfo?(drs.bugzilla) → needinfo?(anshulj)
Clearing the nom while we have more details and are able to reproduce on our builds.
Status: NEW → UNCONFIRMED
Ever confirmed: false
(Reporter)

Comment 6

3 years ago
Gecko: b09b5066607b72a24db42d7c54b03a2824eea39f
Gaia: 46b590648007d51a0406b21b1d6f98eba8e3898e
Flags: needinfo?(anshulj)
These commits are dated from 2 days ago. No smoketest reports called this issue out on the Flame since. Closing as invalid. Please reopen if you have more information.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
(Reporter)

Comment 8

3 years ago
Johan, not sure what other information you are looking for. We are seeing this issue consistently for few weeks now. Could we at least get some one in the development team to take a look at comment #1
(Reporter)

Comment 9

3 years ago
I am still seeing the issue so reopening to get someone from development team at Moz to take a look.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INVALID → ---
(Reporter)

Comment 10

3 years ago
See bug 1127113#c8
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → WORKSFORME
Marking as duplicate as it was the same root cause as bug 1127113.
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 1127113

Updated

3 years ago
No longer blocks: 1063044
You need to log in before you can comment on or make changes to this bug.