Closed Bug 1127131 Opened 5 years ago Closed 5 years ago

[RTL] hitting home to cancel out of Rocketbar from the status menu can cause it to overlay on top of an app or homescreen

Categories

(Firefox OS Graveyard :: Gaia::Search, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(feature-b2g:2.2+, b2g-v2.1 ?, b2g-v2.2 ?, b2g-master affected)

VERIFIED FIXED
2.2 S6 (20feb)
feature-b2g 2.2+
Tracking Status
b2g-v2.1 --- ?
b2g-v2.2 --- ?
b2g-master --- affected

People

(Reporter: nhirata, Assigned: gmarty)

References

Details

(Whiteboard: [2.2-bug-bash] [systemsfe] )

Attachments

(4 files)

Attached image 2015-01-29-00-33-06.png
Build ID               20150128010234
Gaia Revision          1d53fb07984298253aad64bfa4236b7167ee3d4d
Gaia Date              2015-01-27 16:20:39
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/b2b10231606b
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150127.035842
Firmware Date          Tue Jan 27 03:58:52 EST 2015
Bootloader             L1TC000118D0



Steps to Reproduce
1. launch rocketbar 
2. do a search for test without hitting return
3. tap home

Expected Results
no overlay of the rocketbar information on the homescreen

Actual Results
based on the timing of cancelling it can overlay on top of the homescreen or any other app (ie settings if you already happen to be in settings and then invoke the rocketbar from the status and hit home )

Other Notes
similar to bug 1028661
Attached image 2015-01-28-23-19-50.png
Another screenshot this time with settings being in the background
triage: P1 -- Need to re-test this one after bug 1121748 lands.
feature-b2g: --- → 2.2+
Depends on: 1121748
Priority: -- → P1
Whiteboard: [2.2-bug-bash] → [2.2-bug-bash] [systemsfe]
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15445/
Flags: in-moztrap+
Dear Candice,
Can you help to find someone help on this bug?
Thanks!
Flags: needinfo?(cserran)
ni'ing Michael for update and assignment
Flags: needinfo?(cserran) → needinfo?(mhenretty)
qawanted to see if this is fixed now that bug 1121748 landed.
Flags: needinfo?(mhenretty)
Keywords: qawanted
I was unable to reproduce the original bug on a 1/28 nightly user build. Since I couldn't repro the bug, I wouldn't know if it's fixed. No matter what timing I hit the home button I couldn't get the bug. Bug repro rate: 0 out of ~40 attempts.

Device: Flame 2.2
BuildID: 20150128002506
Gaia: cd42b034fd2825c3675ace3a67f5775eb61c2d60
Gecko: d824c65a6a2b
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Leaving qawanted tag for someone else to attempt.
Flags: needinfo?(ktucker)
Flags: needinfo?(ktucker)
Flags: needinfo?(nhirata.bugzilla)
I was unable to reproduce this issue on the latest tinderbox build or tinderbox builds from around the same time as the write up.  Leaving qawanted for another attempt.


Environmental Variables:
Device: Flame 3.0
BuildID: 20150128120131
Gaia: 782d371263911a526870263bffcb419b52c7c88a
Gecko: 1daa622bbe42
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Environmental Variables:
Device: Flame 3.0
BuildID: 20150206083524
Gaia: 0244121522343877d65a69377226a836688e3004
Gecko: e0f56d3f1fc0
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
Flags: needinfo?(ktucker)
Assignee: nobody → mhenretty
Target Milestone: --- → 2.2 S6 (20feb)
I was also unable to reproduce this issue after about 40 attempts on the original build. The homescreen is displayed properly when pressing the home button from the rocket bar search screen.

Environmental Variables:
Device: Flame 3.0
Build ID: 20150128010234
Gaia: 1d53fb07984298253aad64bfa4236b7167ee3d4d
Gecko: b2b10231606b
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
QA Whiteboard: [QAnalyst-Triage?]
Thanks everyone, I'm satisfied this is fixed.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(nhirata.bugzilla)
Flags: needinfo?(ktucker)
Keywords: qawanted
Resolution: --- → FIXED
Attached image 2015-02-09-13-40-47.png
I was still able to get the keyboard to overlay the homescreen after tapping home.

STR: 
1. launch settings app
2. while it's loading tap the rocketbar
3. while rocketbar is loading tap home.

Build ID               20150209010211
Gaia Revision          0d7b35f23402c4cb29bca6b98280fec48a196dec
Gaia Date              2015-02-08 20:44:20
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/3436787a82d0
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150209.045655
Firmware Date          Mon Feb  9 04:57:06 EST 2015
Bootloader             L1TC000118D0
It's not quite fixed.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Guillaume, I've got a fun one for you!
Assignee: mhenretty → gmarty
Adding qawanted. Can we do branch checks here? This feels like it might be a regression.
status-b2g-v2.1: --- → ?
status-b2g-v2.2: --- → ?
Keywords: qawanted
There are some confusions about this bug.

1) The bug was filed as part of 2.2 bug bash, but original reporter's environmental variables seems to indicate it's using a Gecko in 3.0 master. I was misled by the 2.2 bug bash tag and feature 2.2+ hence tested it in 2.2 and couldn't repro. However, comment 8 and comment 9 did test in master and couldn't repro either.

2) Reporter re-opened the bug with a different set of steps and perhaps showing a different bug. I followed those steps but I couldn't get the keyboard to permanently overlay with homescreen. I can only get it to show briefly for about a second after tapping home. And even that the repro rate is only about 1/5 or lower. I did notice that status bar becomes gray-colored as if it's in the background, until I go into another app. The status bar issue can be reliably reproduced. Also this is not specific to RTL. I can get the keyboard to briefly appear and status bar showing wrong color after tapping home in English as well.

NI reporter on:
1) Was this ever seen on 2.2? Or has it always been 3.0 master that this occurred on?

2) Please elaborate on what is being seen on comment 11. Does the keyboard permanently overlay Homescreen, or briefly? Is this indeed the same as original bug? What is the repro rate? A video would really help, so we can be on the same page.

Tested on:
Device: Flame 3.0
BuildID: 20150209010211
Gaia: 0d7b35f23402c4cb29bca6b98280fec48a196dec
Gecko: 3436787a82d0
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(nhirata.bugzilla)
Flags: needinfo?(ktucker)
I think I did see this on 2.2 as well as master during the bug bash.

Having said that, there's still a colorization issue where I'm seeing the status turn grey when doing these steps on 2.2

Not sure if that may indicate anything important though.
Flags: needinfo?(nhirata.bugzilla)
Actually, Pi Wei is right.  I should open a separate bug in regards to what I see in comment 11.
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Clearing qawanted request.
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
See Also: → 1132262
Attached video Verify_Pass.mp4
This problem is verified pass on latest build of Flame 2.2, Flame 3.0, N5 2.2 and N5 3.0 by the STR in comment 0.
Actual result: After tap Home button to go back to homescreen, There's no overlay of the rocketbar information on the homescreen.
See attachment: Verify_Pass.mp4
Rate: 0/40

Device: Flame 2.2 (Pass)
Build ID               20150525162504
Gaia Revision          144673a413586f98b5e2c27b781c1a539611f754
Gaia Date              2015-05-25 02:01:14
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/115112d51e08
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150525.202102
Firmware Date          Mon May 25 20:21:12 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (Pass)
Build ID               20150525160205
Gaia Revision          5bcc08a732163087999251b523e3643db397412c
Gaia Date              2015-05-24 14:44:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/b6623a27fa64
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150525.192755
Firmware Date          Mon May 25 19:28:07 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 2.2 (Pass)
Build ID               20150525002504
Gaia Revision          144673a413586f98b5e2c27b781c1a539611f754
Gaia Date              2015-05-25 02:01:14
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c4db2af40b1b
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150525.041303
Firmware Date          Mon May 25 04:13:19 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5 3.0 (Pass)
Build ID               20150525160205
Gaia Revision          5bcc08a732163087999251b523e3643db397412c
Gaia Date              2015-05-24 14:44:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/b6623a27fa64
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150525.192207
Firmware Date          Mon May 25 19:22:24 EDT 2015
Bootloader             HHZ12f

Thanks!
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.