Closed Bug 1127257 Opened 7 years ago Closed 7 years ago

[Settings][RTL] Sliding animation for subpanels are wrong.

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

x86
macOS
defect
Not set
normal

Tracking

(b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S5 (6feb)
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: eragonj, Assigned: eragonj)

References

Details

Attachments

(1 file)

In settings app, if users change its locales to Arabic. The animation of sliding effect is wrong because subpanels are sliding in from left.

Please check the spec here : https://wiki.mozilla.org/L10n:B2G/RTL#Spatial_metaphors

[Actual result]
subpanels should be sliding in from left.

[Expect result]
subpanels should be sliding in from right.
Attached file patch
Arthur, can you help me review this simple patch ? Thanks :)
Attachment #8556831 - Flags: review?(arthur.chen)
Comment on attachment 8556831 [details] [review]
patch

r=me, thanks.
Attachment #8556831 - Flags: review?(arthur.chen) → review+
blocking-b2g: --- → 2.2?
Thanks Arthur, landed on master: https://github.com/mozilla-b2g/gaia/commit/2d9d19a3c53b06b4ae15a5436d369b0bc4857665
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
blocking-b2g: 2.2? → ---
Comment on attachment 8556831 [details] [review]
patch

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): N/A
[User impact] if declined: The transition does not follow the guideline and leads to bad user experience.
[Testing completed]: Testing on the device.
[Risk to taking this patch] (and alternatives if risky): N/A
[String changes made]: N/A
Attachment #8556831 - Flags: approval-gaia-v2.2?
Attachment #8556831 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified Fixed on the latest Flame 3.0 and 2.2 builds.
Subpanels correctly slide in from the Right.

Environmental Variables:
Device: Flame 3.0 (319MB)(Full Flash)
Build ID: 20150205010209
Gaia: 2b83a6d5d1185a438b5bbd287497ac2743b501db
Gecko: 34a66aaaca81
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Environmental Variables:
Device: Flame 2.2 (319MB)(Full Flash)
Build ID: 20150204002509
Gaia: a4c4cc86303a554facb8f45b7e764e5c4473c3de
Gecko: 8669c26fd4a5
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15992/
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.