Closed Bug 1127884 Opened 8 years ago Closed 8 years ago

The "Unresponsive script" warning appears on Facebook page

Categories

(Core Graveyard :: Plug-ins, defect)

36 Branch
x86
All
defect
Not set
normal

Tracking

(firefox35 wontfix, firefox36+ wontfix)

RESOLVED WORKSFORME
Tracking Status
firefox35 --- wontfix
firefox36 + wontfix

People

(Reporter: cbadau, Unassigned)

Details

Attachments

(1 file)

Attached image issue.png
Reproducible on Firefox 36 Beta 5 (buildID: 20150129200438)
Mozilla/5.0 (Macintosh; Intel MAC OS X 10.9; rv:36.0) Gecko/20100101 Firefox/36.0

I had several sites opened: Facebook, Youtube, Yahoo Games (https://games.yahoo.com/). I navigated on those sites, I played some Youtube videos, I played some Yahoo Games. After a while, when I was on Facebook page I received the following warning: "Warning: Unresponsive script" - please see screenshot "issue.png". After that, Firefox is unresponsive because this warning message appears continuous. I had to force quit Firefox. 

I had the following error in Browser Console: http://pastebin.mozilla.org/8442572

I don't have proper STR.
(In reply to Camelia Badau, QA [:cbadau] from comment #0)
> I had the following error in Browser Console:
> http://pastebin.mozilla.org/8442572

Since this pastebin may or may not disappear, I'm posting the contents here:

    Error: Script terminated by timeout at:
    t.prototype.$VideoPlayerFlashApi5@https://fbstatic-a.akamaihd.net/rsrc.php/v2/yy/r/GN23mC2ZFkG.js:13:4013
    t.prototype.getVideoInfo@https://fbstatic-a.akamaihd.net/rsrc.php/v2/yy/r/GN23mC2ZFkG.js:13:3080
    ja.prototype.$VideoPlayerControllerM@https://fbstatic-a.akamaihd.net/rsrc.php/v2/yR/r/yj3QHOlIs0O.js:27:13736
    ja.prototype.getDebugInfo@https://fbstatic-a.akamaihd.net/rsrc.php/v2/yR/r/yj3QHOlIs0O.js:27:13829
    ja.prototype.$VideoPlayerControllero@https://fbstatic-a.akamaihd.net/rsrc.php/v2/yR/r/yj3QHOlIs0O.js:27:4439
    ja.prototype.handleFlashApiFactoryError@https://fbstatic-a.akamaihd.net/rsrc.php/v2/yR/r/yj3QHOlIs0O.js:27:4906
    t.prototype.$VideoPlayerFlashApi5@https://fbstatic-a.akamaihd.net/rsrc.php/v2/yy/r/GN23mC2ZFkG.js:13:4112
    t.prototype.getVideoInfo@https://fbstatic-a.akamaihd.net/rsrc.php/v2/yy/r/GN23mC2ZFkG.js:13:3080
    ja.prototype.$VideoPlayerControllerM@https://fbstatic-a.akamaihd.net/rsrc.php/v2/yR/r/yj3QHOlIs0O.js:27:13736
    ja.prototype.g GN23mC2ZFkG.js
Potential major regression
Since this is mac, the chances of this having to do with protected-mode or sandboxing are very slim.
I reproduced this issue also on Firefox 35.0.1 (buildID: 20150122214805). It appeared on Facebook after about 3,4 hours of using Facebook, Youtube and Yahoo games. 

Also, I want to mention that on Firefox 36 (Beta 5) I used the "Youtube Flash Player 1.2" add-on (to force Flash Player usage on YouTube). On Firefox 35.0.1 I didn't use it anymore, because Youtube still uses Flash Player for that browser version.
I reproduced the issue also on Firefox 36 Beta 6 (buildID: 20150202183609) on Mac OSX 10.8.5 (on a different machine - not the one mentioned on c#0). 
The issue may be caused by the Facebook page because I've reproduced it when I navigated on Facebook and Youtube, but also the issue appeared when I have opened only Facebook page (on a clean profile).
I had it also under Linux (Debian)
OS: Mac OS X → All
Sylvestre - Did we contact Facebook about this issue?
Flags: needinfo?(sledru)
Flags: needinfo?(tellrob)
Flags: needinfo?(paul)
Flags: needinfo?(sdwilsh)
Lawrence, I didn't because I had the feeling that it was caused by Firefox itself, not Facebook but I might be wrong.
FYI, I didn't see this issue recently.
Flags: needinfo?(sledru)
Wontfix for 36. I didn't see it and it seems that the issue has been fixed by Facebook.
Camelia - Can you confirm that this is no longer an issue?
Flags: needinfo?(camelia.badau)
I've tested on Mac OS X 10.9.5 using Firefox 36 RC Build 1 (buildID: 20150219174507) and Build 2 (buildID: 20150222232811) and I can't reproduce this issue anymore.
Flags: needinfo?(camelia.badau)
Given that Camelia can no longer reproduce, I'm resolving this bug as worksforme.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
Flags: needinfo?(tellrob)
Flags: needinfo?(sdwilsh)
Flags: needinfo?(paul)
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.