All users were logged out of Bugzilla on October 13th, 2018

b2g-manifests not publishable to partners

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: catlee, Unassigned)

Tracking

Details

(Reporter)

Description

4 years ago
The v2.2 branch of b2g-manifests have gotten out of sync due to a non-ff commit on github. compare:

https://git.mozilla.org/?p=b2g/b2g-manifest.git;a=shortlog;h=refs/heads/v2.2

vs

https://github.com/mozilla-b2g/b2g-manifest/commits/v2.2
ni :mwu

Looks like someone force pushed a non-fast-forward commit to github. We aren't allowed to publish non-fast-forward changes to b2g partners with notification.

Do you want to fix the repo on github? Or have us do the notification to all partners and publish the non-fast-forward changes? The decision is up to the b2g folks.
Flags: needinfo?(mwu)
Summary: b2g-manifests out of sync → b2g-manifests not publishable to partners

Comment 2

4 years ago
Non fast-forward commits aren't generally permitted. We should fix it if we can.

Kai-Zhen, it looks like you made the last few commits on this branch. Do you have any idea what's going on here?
Flags: needinfo?(mwu) → needinfo?(kli)

Comment 3

4 years ago
Or rather, force pushes aren't generally permitted. Sounds like a force push was done.
Yes, I made the last commit. I know force push is not permitted and I also check my bash_history my last commit is not a force push.
--
git checkout v2.2 
git cherry-pick -m 1 54c033f0489d4a42ff615d9404fa340e68b13cb9
git branch 
git log
git show 2b41acd255577075f01c17e371f3c972bb394679
git log v2.2...origin/v2.2 
git push b2g-push v2.2 


The current problem is conflict between these two commits which are also made by me. I think I did some thing wrong. But I didn't find the cause which made this error. 

github: 89b3f66acc69f0fa44fb27dce40bfe34eaf6b641
git.m.o: 1c965d284fbc9886ce3be156960bf6f23149d832


Now, I think we can fix this problem on github.
1) It needs to rebase github v2.2 branch to git.m.o: 1c965d284fbc9886ce3be156960bf6f23149d832
2) Then need to make a force push to github v2.2 branch.
After step 1 and 2, all other mirror side can be synced from github successfully.
Flags: needinfo?(kli)
Michael, do you agree to fix this on github? If you agree, I'll do it.
Flags: needinfo?(mwu)

Comment 6

4 years ago
Sure, the solution sounds fine to me. Might have to warn people though - I don't know what repo sync will do. Thanks!
Flags: needinfo?(mwu)
It is fixed on github. I also verified that there is no problem on repo sync after new v2.2 branch is pushed to github. As there is no conflict between old and new v2.2 branch, a 3-way merge will be taken place during repo sync and everything will be fine then.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Comment 8

4 years ago
AFAIK GitHub doesn't allow you to install a hook or similar that would prevent force pushes. Preventing force pushes thus boils down to a culture thing. Point goes to self-hosted version control.
You need to log in before you can comment on or make changes to this bug.