Can not drag bookmark to folder

VERIFIED DUPLICATE of bug 79752

Status

VERIFIED DUPLICATE of bug 79752
17 years ago
14 years ago

People

(Reporter: zhayupeng, Assigned: paulkchen)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I can not drag bookmark to folder at sometime like following.

Mozilla release:0.9.6
Platform: Window2000, Solaris

Reproduce:
1)Open "Manage Bookmarks" window
2)Create a folder like "test1"
3)Create another folder like "test2"
4)Drag "test2" into "test1" (test2 become a child of test1)
5)Drag a bookmark to folder "test2" (So, this bookmark is a child of folder "test2")
Everything seems OK now... but please be patient and go ahead...
6)Close "Manage Bookmarks" window
7)Reopen "Manage Bookmarks" window
8)Try to drag the bookmark in folder "test2" to parent folder "test1"
What happen? 
On Window2000, the drag icon is "Unavailable"
On Solaris 2.8 drag icon is OK, but nothing happen when I release the mouse button

Comment 1

17 years ago
This seems like a duplicate of bug 79752, though the description here is a lot
clearer than there.  I can confirm this behavior for Solaris build 200112922.

*** This bug has been marked as a duplicate of 79752 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

17 years ago
In this file: bookmarksDD.js
Following code at line 142

if (rdfParent && rdfParent.getAttribute("container") == "true"){
......
}

The condition's result will always be false on the Reproduce step 8(see above),
when I drag bookmark over to folder test1...
It because 'rdfParent.getAttribute("container")' returns nothing.
This happens on Windows Build (Milestone096), and this is the reason that drag
icon's status is Unavailable.

But on Solaris, 'rdfParent.getAttribute("container")' return 'true' on Step 8,
but nothing happened after release mouse button...

I will look forward to find the reason...

mass-verifying Duplicate bugs which haven't changed since 2001.12.31.

set your search string in mail to "CitizenGKar" to filter out these messages.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.