Closed Bug 1128076 Opened 5 years ago Closed 5 years ago

Clean up naming around unboxed value MIR accesses

Categories

(Core :: JavaScript Engine: JIT, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla39
Tracking Status
firefox39 --- fixed

People

(Reporter: bhackett, Assigned: bhackett)

References

Details

Attachments

(1 file)

After bug 1116855, MLoadTypedArrayElement will be used for typed arrays, typed object, and unboxed objects.  The alias set flag TypedArrayElement is also used for each of these locations.  This op, its LIR version, and other multi-use opcodes should be renamed and cleaned up to better indicate their generic nature.
Attached patch patchSplinter Review
Rename {Load,Store}TypedArrayElement to {Load,Store}UnboxedScalar, along with a few other classes and terms that are used for accesses on objects other than typed arrays.  This also removes some dead PJS code.  FWIW the SetElem_Unsafe stuff seems to also be dead except for a single access in the Array.map self hosted code.
Assignee: nobody → bhackett1024
Attachment #8574379 - Flags: review?(jdemooij)
Comment on attachment 8574379 [details] [diff] [review]
patch

Review of attachment 8574379 [details] [diff] [review]:
-----------------------------------------------------------------

Nice.
Attachment #8574379 - Flags: review?(jdemooij) → review+
https://hg.mozilla.org/mozilla-central/rev/b0993c742a0d
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
You need to log in before you can comment on or make changes to this bug.