Closed Bug 1128117 Opened 6 years ago Closed 6 years ago

Upgrade SemanticForms extension to 3.1

Categories

(Websites :: wiki.mozilla.org, defect)

Production
All
Linux
defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: GPHemsley, Unassigned)

References

()

Details

(Keywords: wsec-xss, Whiteboard: [dev=2015-02-05] [stage=2015-02-05] [prod=2015-02-05])

Attachments

(1 file)

From what I can tell, the patch to SemanticForms that fixed bug 801638 wasn't backported to the REL_1_23 branch. (In fact, it doesn't look like the developer of that extension backports anything.)

We'll have to bypass this by installing a specific version. The first version with the fix is 3.0; the latest version is currently 3.1, and then there's master.

We'll have to decide which one we want to use, and then we'll have to remember to update it as time goes on.

https://git.wikimedia.org/branches/mediawiki%2Fextensions%2FSemanticForms.git
Whiteboard: [dev=2015-02-05]
Update pushed to prod, removing security flag as the issue is resolved.

https://github.com/mozilla/wiki.mozilla.org/pull/7
Group: websites-security
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [dev=2015-02-05] → [dev=2015-02-05] [stage=2015-02-05] [prod=2015-02-05]
You need to log in before you can comment on or make changes to this bug.