If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mozilla never offers to be your default browser

RESOLVED DUPLICATE of bug 97975

Status

SeaMonkey
UI Design
RESOLVED DUPLICATE of bug 97975
16 years ago
13 years ago

People

(Reporter: Matthew Paul Thomas, Assigned: Bill Law)

Tracking

Trunk
Future
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Hixie-P0])

(Reporter)

Description

16 years ago
Build: 2001112708 (and every build before that), Mac OS 9.1

To reproduce:
1.  Install Mozilla.
2.  Run Mozilla.
3.  Quit Mozilla.

What should happen:
*   At some point, you are asked: `Your default Web browser is currently {some
    browser, probably MSIE or 4.x or Opera}. Would you like Mozilla to be your
    default browser instead?'

What actually happens:
*   Your default Web browser remains not-Mozilla.

Comment 1

16 years ago
Some installer work required here.
Blocks: 89907

Comment 2

16 years ago
-> default assignee
Assignee: pchen → trudelle

Comment 3

16 years ago
->law, cc jag
Assignee: trudelle → law
(Assignee)

Comment 4

16 years ago
->Installer

If we want to do a runtime check like we do on Windows (to give the user a 
chance to remedy their error if they've installed some other "default browser") 
then I can help describe how it is done on Win32 (if that helps).
Assignee: law → dveditz
Component: XP Apps → Installer
QA Contact: sairuh → bugzilla

Comment 5

16 years ago
not installer. the installer installs mozilla nothing more...
Assignee: dveditz → trudelle
Component: Installer → XP Apps
QA Contact: bugzilla → sairuh

Comment 6

16 years ago
->law.  Bill, I gave this to you because you do this work on Windows.  I cc'd
Jag so he could help you implement it on Mac as well.  Perhaps the assign/cc
should be the other way round, but between the two of you, we should figure out
how/when to do this.
Assignee: trudelle → law
(Assignee)

Comment 7

16 years ago
Future-ing; need Mac expertise which I don't have and this bug isn't high 
enough priority...
Target Milestone: --- → Future
I find it hard to find a higher priority bug.
Whiteboard: [Hixie-P0]
->sdagley? punt as needed...
QA Contact: sairuh → petersen

Comment 10

15 years ago
Yeah, this is a run-time issue, not an installer issue.  There should be a
preference to check at launch time, on by default.  Besides, there is no OSX
installer AFAIK.

By the way, OS should be All, not just 9.x, since OSX has the same issue, unless
the fixes are OS-specific.

Whenever I upgrade Mozilla, OSX decides it can't find the previous version of
Mozilla anymore, so it changes my default browser back to IE.  I always forget
about this until I click a link and IE launches.  So yeah, this is pretty
important.  Wish I had the expertise to fix it.

Comment 11

15 years ago

*** This bug has been marked as a duplicate of 97975 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.