[Loop/Firefox Hello] self conversations should not be possible in guest mode

RESOLVED DUPLICATE of bug 1066019

Status

Hello (Loop)
General
RESOLVED DUPLICATE of bug 1066019
3 years ago
3 years ago

People

(Reporter: alf4pk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150122214805

Steps to reproduce:

Start a new conversation in guest mode, then copy the conversation link and paste it in the address bar of the browser. In the end, join the conversation.


Actual results:

You can start a conversation with yourself. You can do it with how many conversations you want.


Expected results:

Insetead of launching the conversation, firefox should display an error message.
(Reporter)

Updated

3 years ago
OS: All → Windows 7
Hardware: All → x86_64
Summary: self conversations should not be possible in guest mode → [Loop/Firefox Hello] self conversations should not be possible in guest mode
Thanks for the report, I think that the real issue here is that the owner can be confused as to the expected mode of opening the room (we only have one mode currently - via the panel). In bug 1066019 we're planning on making it so that link-clicks in Firefox would also open in the conversation window.

The user story on that bug already has the owner-case defined, so making it do the correct thing (open the conversation as owner) would be easy. If the room's already open, we could provide a visual message or redirect or something. I've updated the user story on that bug with a reference to this one.

We haven't done the breakdown for that work yet, so I'm going to mark this as a duplicate, but the info is stored in the user story on that bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1066019
You need to log in before you can comment on or make changes to this bug.