custom date/time fields are always in server time even when rest of email is in localized time

RESOLVED DUPLICATE of bug 946090

Status

()

RESOLVED DUPLICATE of bug 946090
4 years ago
4 years ago

People

(Reporter: Gijs, Unassigned)

Tracking

Details

(Reporter)

Description

4 years ago
In particular, I get email that says something like:

Phil Ringnalda (:philor) changed Bug 1125677 at 2015-01-31 17:08:24 GMT:

What               Removed          Added
Last Resolved                       2015-01-31 09:08:24 

Note the discrepancy between the timestamps. My bugzilla pref "Timezone used to display dates and times" is set to "Europe/London", so I expect all the timestamps in my bugmail to be in GMT (or, if not, to have a timezone indication).

Updated

4 years ago
Assignee: email-notifications → nobody
Component: Email Notifications → General
Product: Bugzilla → bugzilla.mozilla.org
QA Contact: default-qa
Version: unspecified → Production
last-resolved is a standard bugzilla custom form, so this is an upstream issue.

in the email templates we always do [% new_value FILTER html %], when we should be inspecting the field's type and using the time filter if it's a datetime field.
Assignee: nobody → email-notifications
Component: General → Email Notifications
OS: Windows 8.1 → All
Product: bugzilla.mozilla.org → Bugzilla
QA Contact: default-qa
Hardware: x86_64 → All
Summary: "Last resolved" timestamp is always in server time even when rest of email is in localized time → custom date/time fields are always in server time even when rest of email is in localized time
Version: Production → unspecified
"standard bugzilla custom form" --> "standard bugzilla custom field".

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 946090
You need to log in before you can comment on or make changes to this bug.