[RTL][Calendar]The event detail view is not mirrored.

VERIFIED DUPLICATE of bug 1059017

Status

defect
P2
normal
VERIFIED DUPLICATE of bug 1059017
5 years ago
4 years ago

People

(Reporter: lulu.tian, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(2 attachments)

Posted image details.png
[1.Description]:
[RTL][Calendar]When you check the event detailst, the detail view is not mirrored, and the details page can be scrolled to left/right.
See attachment:details.png

[2.Testing Steps]: 
Prerequisite: Set system language as Arabic.
1. Launch Calendar app.
2. Create an event.
3. Tap the event to check detail.

[3.Expected Result]: 
3. The details should be right-aligned.

[4.Actual Result]: 
3. The details are shown at left of screen.

[5.Reproduction build]: 
Flame 2.2 build:
Gaia-Rev        d6141fa3208f224393269e17c39d1fe53b7e6a05
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/f7414413e3a5
Build-ID        20150201002504
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150201.043120
FW-Date         Sun Feb  1 04:31:31 EST 2015
Bootloader      L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
QA Whiteboard: [rtl-impact]
ni? to Delphine to investigate after bug 1059017 lands.
feature-b2g: --- → 2.2+
Flags: needinfo?(lebedel.delphine)
Priority: -- → P2
This is working properly after the landing of bug 1059017.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(lebedel.delphine)
Resolution: --- → DUPLICATE
Duplicate of bug: 1059017
Flags: in-moztrap-
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15881/
Flags: in-moztrap- → in-moztrap+
Posted image Verify1_v2.2.png
This issue is verified as pass on latest Flame v2.2/master and N5 v2.2/master build by the same STR in comment 0, the event details view is right-aligned.

See attachment:Verify1_v2.2.png.
Reproducing rate:0/10

Device: Flame v2.2 build (Pass)
Build ID               20150721162504
Gaia Revision          e1e6317f17a840b19af9dbb25f5a771d8d9fa161
Gaia Date              2015-07-15 21:05:11
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a73051740290
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150721.203051
Firmware Date          Tue Jul 21 20:31:03 EDT 2015
Bootloader             L1TC000118D0

Device: Flame master build (Pass)
Build ID               20150721160205
Gaia Revision          84c3bf622e211046d905803b34de5d331761f22d
Gaia Date              2015-07-21 16:28:35
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1875a5584e5f
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150721.194129
Firmware Date          Tue Jul 21 19:41:42 EDT 2015
Bootloader             L1TC000118D0

Device: N5 v2.2 build (Pass) 
Build ID               20150721002506
Gaia Revision          e1e6317f17a840b19af9dbb25f5a771d8d9fa161
Gaia Date              2015-07-15 21:05:11
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/1bc400014f71
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150721.041313
Firmware Date          Tue Jul 21 04:13:29 EDT 2015
Bootloader             HHZ12f

Device: N5 master build (Pass)
Build ID               20150721160205
Gaia Revision          84c3bf622e211046d905803b34de5d331761f22d
Gaia Date              2015-07-21 16:28:35
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1875a5584e5f
Gecko Version          42.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150721.211608
Firmware Date          Tue Jul 21 21:16:23 EDT 2015
Bootloader             HHZ12f
Status: RESOLVED → VERIFIED
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.