[CostControl] Widget broken after switching data sim

RESOLVED FIXED in 2.2 S6 (20feb)

Status

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: mai, Assigned: mai)

Tracking

unspecified
2.2 S6 (20feb)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 fixed, b2g-master fixed)

Details

Attachments

(2 attachments)

(Assignee)

Description

4 years ago
When switching sim card from dausage only to balance, the widget doesn't work.^
Preconditions:
FTE done.
Two sims:
 SIM1 only data
 SIM2 balance and data

STR: 
  1) Insert two sim card and power on the phone;
  2) Slide down the notification bar and load the widget with the SIM1.
  3) Go to "Settings"->SIM Manager->Data,changing to SIM card 2.
  4) Slide down the notification bar again 

CURRENT BEHAVIOUR:  
  Observe the console(exists JavaScript errors) or try to refresh the widget (it doesn't work)
 
EXPECTED BEHAVIOUR:
  It should work normally when changing sim card.
(Assignee)

Updated

4 years ago
Assignee: nobody → marina.rodrigueziglesias
(Assignee)

Comment 2

4 years ago
Posted file patch v1.0
Hi Salva,
would you mind to review the patch?
Regards
Attachment #8558584 - Flags: review?(salva)
[Blocking Requested - why for this release]: a possible DUAL SIM scenario breaks one of the main functionalities.
blocking-b2g: --- → 2.2?
OS: Windows 7 → Gonk (Firefox OS)
Hardware: x86_64 → ARM
Comment on attachment 8558584 [details] [review]
patch v1.0

Hi Marina. In general, the fix seems great to me but I left you a couple of nits on GitHub. We should simplify the test or increase its readability. I gave you some feedback on GitHub about this. Ask for my review when you finish to make the proper modifications.

Thank you and nice catch!
Attachment #8558584 - Flags: review?(salva)
triage: Broken feature, 2.2+
blocking-b2g: 2.2? → 2.2+
Status: NEW → ASSIGNED
(Assignee)

Comment 6

4 years ago
Comment on attachment 8558584 [details] [review]
patch v1.0

Updated the pr with your comments,
Regards,
Mai
Attachment #8558584 - Flags: review?(salva)
Comment on attachment 8558584 [details] [review]
patch v1.0

Very good work. Please, address my comments on GitHub and you're done.

Thank you Mai.
Attachment #8558584 - Flags: review?(salva) → review+
(Assignee)

Comment 8

4 years ago
Master:01e4555974f19757f1add02c6ffec1d596d4209f
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S6 (20feb)
(Assignee)

Comment 9

4 years ago
Comment on attachment 8558584 [details] [review]
patch v1.0

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Feature
[User impact] if declined: The widget is broken after switching data sim
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): Low risk
[String changes made]:No
Attachment #8558584 - Flags: approval-gaia-v2.2?(release-mgmt)
Attachment #8558584 - Flags: approval-gaia-v2.2?(release-mgmt) → approval-gaia-v2.2+
You need to log in before you can comment on or make changes to this bug.