Like AppWindow#tryWaitForFullRepaint, BrowserMixin#waitForNextPaint should have a fast path for the homescreen

RESOLVED DUPLICATE of bug 1117444

Status

RESOLVED DUPLICATE of bug 1117444
4 years ago
4 years ago

People

(Reporter: etienne, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

4 years ago
This could lead to the homescreen not being ready more often. But it's shredding 500ms of a delay between a frequent user action and the feedback, so I think it's worth exploring.
Created attachment 8557996 [details] [review]
[PullReq] etiennesegonzac:bug-1128583 to mozilla-b2g:master
(Reporter)

Comment 2

4 years ago
Comment on attachment 8557996 [details] [review]
[PullReq] etiennesegonzac:bug-1128583 to mozilla-b2g:master

What do you think?
Attachment #8557996 - Flags: review?(alive)
Comment on attachment 8557996 [details] [review]
[PullReq] etiennesegonzac:bug-1128583 to mozilla-b2g:master

Ya for perf reason.
Attachment #8557996 - Flags: review?(alive) → review+

Comment 4

4 years ago
Dear Alive, Etienne,

After load this patch, while back to homescreen, homescreen would first flash the screen.

For QA would calculate hot exit time with flash time. Could we let homescreen not flash ?

Thanks.
Flags: needinfo?(etienne)
Flags: needinfo?(alive)
(Reporter)

Comment 5

4 years ago
Comment on attachment 8557996 [details] [review]
[PullReq] etiennesegonzac:bug-1128583 to mozilla-b2g:master

(In reply to ben.song from comment #4)
> Dear Alive, Etienne,
> 
> After load this patch, while back to homescreen, homescreen would first
> flash the screen.
> 
> For QA would calculate hot exit time with flash time. Could we let
> homescreen not flash ?
> 
> Thanks.

I'll try to come up with a better approach.
Obsoleting the patch in the meantime...
Attachment #8557996 - Attachment is obsolete: true
Flags: needinfo?(etienne)
(Reporter)

Updated

4 years ago
Flags: needinfo?(alive)
(Reporter)

Comment 6

4 years ago
Closing this one in favor of bug 1117444 which doesn't imply a solution but just explains the "bug".
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1117444
You need to log in before you can comment on or make changes to this bug.