If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Unity Mandlebrot GPU benchmark doesn't run properly on Windows in Beta 36

NEW
Unassigned

Status

()

Core
Canvas: WebGL
3 years ago
3 years ago

People

(Reporter: jrmuizel, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

(Reporter)

Description

3 years ago
The first benchmark (Mandlebrot GPU) of http://beta.unity3d.com/jonas/WebGLBenchmark/ just paints a green square when I run it in FF release and with d3d11 turned off. Turning d3d11 on seems to fix it.

Updated

3 years ago
Blocks: 1128627

Comment 1

3 years ago
This might be a duplicate of this: 1122465

Comment 2

3 years ago
https://bugzilla.mozilla.org/show_bug.cgi?id=1122465
(Reporter)

Comment 3

3 years ago
(In reply to Martin Best (:mbest) from comment #2)
> https://bugzilla.mozilla.org/show_bug.cgi?id=1122465

I can reproduce this on trunk and in FF 30 which suggests that it is not this problem.
I'm assuming we're talking Windows here :)
OS: Mac OS X → Windows 7
On a related, but perhaps irrelevant note, OS X Aurora with Skia is about 5% better on this benchmark than Nightly with Quartz.  May get to checking if it's Skia or version that make a difference.
(Reporter)

Comment 6

3 years ago
(In reply to Milan Sreckovic [:milan] from comment #5)
> On a related, but perhaps irrelevant note, OS X Aurora with Skia is about 5%
> better on this benchmark than Nightly with Quartz.  May get to checking if
> it's Skia or version that make a difference.

Shouldn't make a difference as this uses WebGL not 2D canvas afaik.

Updated

3 years ago
Blocks: 1128908
(In reply to Jeff Muizelaar [:jrmuizel] from comment #6)
> (In reply to Milan Sreckovic [:milan] from comment #5)
> > On a related, but perhaps irrelevant note, OS X Aurora with Skia is about 5%
> > better on this benchmark than Nightly with Quartz.  May get to checking if
> > it's Skia or version that make a difference.
> 
> Shouldn't make a difference as this uses WebGL not 2D canvas afaik.

Exactly, which is why it's weird...
Martin, can you attach the about:support graphics section form the computer you have this failing at?
Flags: needinfo?(mbest)
This is not a recent bug (see comment 3), but there is a recent fix; Aurora fails on 01/06 build, but works fine in 02/03.  This is D3D11/D2D1.1.
Flags: needinfo?(mbest)
Summary: Unity Mandlebrot GPU benchmark doesn't run properly with D3D9 on Intel HW → Unity Mandlebrot GPU benchmark doesn't run properly on Windows - recently fixed in Aurora 37
Summary: Unity Mandlebrot GPU benchmark doesn't run properly on Windows - recently fixed in Aurora 37 → Unity Mandlebrot GPU benchmark doesn't run properly on Windows in Beta 36
This is fixed by D3D11 ANGLE, so not the best candidate for uplifting.
I was using a beta driver and seeing some very strange behavior in beta yesterday.  When I went back and reverted to stable drivers, all was resolved.  I still see the missing Mandlebrot texture when D3D9 is in play but the scores and WebGL performance are now consistent across versions.  Looks like the Beta drivers were not optimized properly for D3D9.

Updated

3 years ago
Whiteboard: [gfx-noted]
You need to log in before you can comment on or make changes to this bug.