Closed Bug 1128692 (user_directories) Opened 5 years ago Closed 5 years ago

Mozilla products doesn't allow to use a custom user configuration directory

Categories

(Core :: XPCOM, defect)

Other Branch
x86_64
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 259356

People

(Reporter: psychoslave, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141113113219

Steps to reproduce:

  # configure a Linux environment as follow :
  export MOZ_USER_DIR=${XDG_CONFIG_HOME}/mozilla
  export MOZ_PLUGIN_PATH=$MOZ_USER_DIR/plugins
  # moving mozilla user directory in the customized place
  mv ~/.mozilla ${XDG_CONFIG_HOME}/mozilla
  firefox


Actual results:

Running firefox, it didn't found my existing profile and created a new one in ~/.mozilla


Expected results:

Firefox, and other mozilla products, should provide and respect environment variables at least for the following elements :
 - the path were the configuration elements are stored
 - the path were the cached elements are stored

Optionaly it shoul also provide better granularity for stuff like applications, extensions and so on.

In my specific case, I would like to use XDG specification directories, but the more flexible the better.

Relevant document seems to be :
- http://mxr.mozilla.org/mozilla-central/source/xpcom/io/nsAppFileLocationProvider.cpp
- http://mxr.mozilla.org/mozilla-central/ident?i=DEFAULT_PRODUCT_DIR
- http://standards.freedesktop.org/basedir-spec/basedir-spec-latest.html
I'm going to mark this as a duplicate of the longstanding "use XDG dirs" bug. This is not a high priority for the project, although I think we would take a patch that was sufficiently safe and kept existing users' profiles intact.

MOZ_USER_DIR is not a runtime configuration parameter, and epxorting it as you did should have no effect.

You can put the profile directory anywhere you like by launching Firefox with -profile /path/to/profile
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 259356
Thanks for the `-profile` suggestion. But as far as I understand, it wouldn't enable me to move the whole ~/.mozilla content, which is my goal.

Can you suggest relevant documentation that I may read in order to make this patch ? I can code but I'm not familiar with the mozilla development tool chain.

Also, as I said, if I intent to use XDG specification directories, exposing mozilla specific environement variables seems far more interesting to. Less specific, more flexible, better portability. I didn't red the whole bug report, but it doesn't seems to suggest to go this way. I even red some post complaining about how hard migration would be with an distributed by topic profile: with a set of environement variables, you can easily stay backward compatible while allowing user to put their miscellaneous data where they like.

Looks like I can't post on the bug report you pointed, so I post here.

Looking foward for documentation enabling me to do the job.
Alias: user_directories
I've un-restricted bug 259356 so you can comment there, although please read the entire bug in detail before commenting, to avoid duplication ;-)

When I say migration, I mean *automatic* migration, so that users don't have to set any environment variables and their Firefox continues to work seamlessly.
You need to log in before you can comment on or make changes to this bug.