Closed Bug 11287 Opened 21 years ago Closed 21 years ago

Can crash brower by dismissing profile dialog and going to mozilla.org

Categories

(Core Graveyard :: Profile: BackEnd, defect, P2, major)

x86
Windows NT

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: slogan, Assigned: law)

References

Details

Do what is necessary to cause the
profile dialog to come up at start of
apprunner. There is a file in
c:\winnt, mozprofile.dat I think is
the name, removing it should do the
trick. Start the browser. Dismiss the
profile dialog that displays by using
the window close control (the little X
in the upper right hand corner). Once
apprunner loads, type www.mozilla.org
in the location bar. You should crash.
Stack is below:

nsBrowserAppCore::LoadUrl(nsBrowserAppCore * const 0x0a6447dc, const nsString &
{...}) line 821 + 46 bytes
BrowserAppCoreLoadUrl(JSContext * 0x09f5ca40, JSObject * 0x0a386190, unsigned
int 1, long * 0x0119eff0, long * 0x0012e5dc) line 383 + 16 bytes
js_Invoke(JSContext * 0x09f5ca40, unsigned int 1, unsigned int 0) line 654 + 26
bytes
js_Interpret(JSContext * 0x09f5ca40, long * 0x0012ee08) line 2228 + 15 bytes
js_Invoke(JSContext * 0x09f5ca40, unsigned int 0, unsigned int 0) line 670 + 13
bytes
js_Interpret(JSContext * 0x09f5ca40, long * 0x0012f5f0) line 2228 + 15 bytes
js_Invoke(JSContext * 0x09f5ca40, unsigned int 1, unsigned int 2) line 670 + 13
bytes
js_InternalCall(JSContext * 0x09f5ca40, JSObject * 0x011ae5f0, long 18540032,
unsigned int 1, long * 0x0012f730, long * 0x0012f738) line 747 + 15 bytes
JS_CallFunctionValue(JSContext * 0x09f5ca40, JSObject * 0x011ae5f0, long
18540032, unsigned int 1, long * 0x0012f730, long * 0x0012f738) line 2643 + 29
bytes
nsJSEventListener::HandleEvent(nsIDOMEvent * 0x0a66e730) line 97 + 34 bytes
nsEventListenerManager::HandleEvent(nsIPresContext & {...}, nsEvent *
0x0012fa78, nsIDOMEvent * * 0x0012f870, unsigned int 3, nsEventStatus &
nsEventStatus_eIgnore) line 789 + 21 bytes
nsGenericElement::HandleDOMEvent(nsIPresContext & {...}, nsEvent * 0x0012fa78,
nsIDOMEvent * * 0x0012f870, unsigned int 1, nsEventStatus &
nsEventStatus_eIgnore) line 784
nsHTMLInputElement::HandleDOMEvent(nsHTMLInputElement * const 0x0a1bd67c,
nsIPresContext & {...}, nsEvent * 0x0012fa78, nsIDOMEvent * * 0x00000000,
unsigned int 1, nsEventStatus & nsEventStatus_eIgnore) line 509 + 31 bytes
PresShell::HandleEvent(PresShell * const 0x09e750e4, nsIView * 0x0a1f2680,
nsGUIEvent * 0x0012fa78, nsEventStatus & nsEventStatus_eIgnore) line 2239 + 39
bytes
nsView::HandleEvent(nsView * const 0x0a1f2680, nsGUIEvent * 0x0012fa78, unsigned
int 8, nsEventStatus & nsEventStatus_eIgnore, int & 0) line 834
nsView::HandleEvent(nsView * const 0x09e754e0, nsGUIEvent * 0x0012fa78, unsigned
int 28, nsEventStatus & nsEventStatus_eIgnore, int & 0) line 819
nsViewManager::DispatchEvent(nsViewManager * const 0x09e75700, nsGUIEvent *
0x0012fa78, nsEventStatus & nsEventStatus_eIgnore) line 1611
HandleEvent(nsGUIEvent * 0x0012fa78) line 67
nsWindow::DispatchEvent(nsWindow * const 0x0a1f22c4, nsGUIEvent * 0x0012fa78,
nsEventStatus & nsEventStatus_eIgnore) line 490 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012fa78) line 515
nsWindow::DispatchKeyEvent(unsigned int 132, unsigned short 13, unsigned int 13)
line 1959 + 15 bytes
nsWindow::OnKeyUp(unsigned int 13, unsigned int 28) line 2221
nsWindow::ProcessMessage(unsigned int 257, unsigned int 13, long -1071906815,
long * 0x0012fdb0) line 2467 + 40 bytes
nsWindow::WindowProc(HWND__ * 0x0097008e, unsigned int 257, unsigned int 13,
long -1071906815) line 563 + 27 bytes
nsTextWidget::TextWindowProc(HWND__ * 0x0097008e, unsigned int 257, unsigned int
13, long -1071906815) line 120
USER32! 77e71250()
Assignee: don → law
Priority: P3 → P2
Target Milestone: M11
Bill, does this happen for you?
Component: Browser-General → Profile Manager
QA Contact: leger → gbush
gbush, can you reprocduce this?
Tested on all Win machines, Mac and Linux
Not able to reproduce on 1999083108 builds
www.mozilla.org is the url on launch
I think this bug may have been fixed since logged-with new debugging statements
on console, Profile Manager is done when browser is launched.
Status: NEW → ASSIGNED
Can we mark this worksforme then?
Blocks: 12696
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → VERIFIED
verified from seamonkey
Component: Profile Manager → Profile Manager BackEnd
Moving all Profile Manager bugs to new Profile Manager Backend component.
Profile Manager component to be deleted.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.