Status

()

RESOLVED FIXED
4 years ago
8 months ago

People

(Reporter: BenWa, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

4 years ago
The following imgur 'gifv' wont load:
http://i.imgur.com/h9wkTKV.gifv

Plays instantly in chrome.
Works here. Mac with today's nightly. It it failing on the webm or mp4 version, or both?
(Reporter)

Comment 2

4 years ago
I don't seem to be able to check. When I try to use the direct URL it just redirects me to the original URL.
https://i.imgur.com/h9wkTKV.mp4 redirects to the .gifv page for me.
https://i.imgur.com/h9wkTKV.webm does not. Which suggests you're getting a page putting the mp4 version first?

I checked by:
1. Right-click on video, select 'Show controls'.
2. Right-click on video again, select 'Show statistics'.
3. Note file type at the start of the overlay.

This must be done quickly, since the control state is lost they they loop the video after playback ends.

You can also check the specified source order by selecting the video element in the devtools inspector and looking at the corresponding html.

Comment 4

4 years ago
Having a lot of .gifv problems for over a month (via reddit and RES) and directly on imgur. I turned off ADP, ghostery, noscript and nothing helps. The :rillian links (and all other reddit .gifv) just give me the 1st frame of the vids only when a separate imgur tab.   IE works fine playing these vids.

FF ESR 31.6.0 and previous ESR versions.
Component: Audio/Video → Audio/Video: Playback

Comment 5

2 years ago
Frankie, do these fail for you?
Flags: needinfo?(francis.uy)

Comment 6

2 years ago
In Mac FFDE 49.0a2, all three of those URLs (when clicked) redirect to https://imgur.com/h9wkTKV and auto-play a video tag with an MP4 file.

When typed or pasted into a blank window, they load http://i.imgur.com/h9wkTKV.mp4
Flags: needinfo?(francis.uy)

Comment 7

2 years ago
Can reproduce this in Linux Ubuntu 16.04 

Application Basics
------------------

Name: Firefox
Version: 49.0
Build ID: 20160920074044
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
OS: Linux 4.4.0-36-generic
Multiprocess Windows: 0/1 (Disabled by add-ons)
Safe Mode: false

Here is one more gifv which cannot be played - http://i.imgur.com/Dkwx3Ay.gifv

Comment 8

2 years ago
When a gifv extension is made gif(at least for imgur), all of them seem to play. Can somebody confirm whether it's an imgur issue or Firefox isssue?

Comment 9

2 years ago
Bishwajeet's gifv works for me on FFDE 51 Mac (as do all the others I've tested) by auto-redirecting to an mp4 copy, regardless of which URL is used.

Some people on Mac are not seeing this problem, while others on Mac & Linux are. We have not identified a distinguishing factor why this is so.
OS: Mac OS X → Unspecified

Comment 10

2 years ago
I've found something that might be related to this.

If you have media.autoplay.enabled setting set to false then you can't manually play any Imgur hosted .gifv files by right-clicking the image and selecting the 'Play' context menu option. It's like the menu option doesn't do anything. This method works fine in release version of Firefox 50.x and it used to work in developer edition until recently.

However if I right-click on the .gifv and select 'Show Controls' and then I get the overlaid Play button. If I click on the play button then .gifv starts playing.

Comment 11

2 years ago
(In reply to sid from comment #10)

I see the exact same behavior as sid in comment #10.  I have autoplay disabled as well (and no, that's not ever going to change), and right-clicking and selecting 'Play' has zero effect in 52, possibly 51 (I didn't check then).  Worked fine in earlier versions.

Comment 12

2 years ago
Another "Me Too".  See https://www.reddit.com/r/firefox/comments/649syo/any_new_config_stuff_regarding_imgur_videos_or/

Config: Win10, FF52.0.2, no add-ons beyond system-provided H264+Widevine. Old, non-technical user.

My test case, from r/aww:

 * http://i.imgur.com/D3Drnvv.gifv:
 --> RtClick->Play: Does NOT play
 --> RtClick->View Video: Does NOT play
 * https://www.reddit.com/r/aww/comments/647kmk/he_can_slide_into_boxes_whats_your_useless_talent/
 --> RtClick->Play: Does NOT play
 --> RtClick->View Video: DOES play, but takes 6-8x the video length to do so.

I HAVE done the "Reset Firefox" thing.  I DO have media.autoplay.whatever set to FALSE.

Has something changed? RtClick-> Play NEVER works now, and RtClick->View Video only works sometimes. Is there a new config parameter or something?

Comment 13

2 years ago
Yet another "me too". I first noticed this behavior about a month ago; it had been fine before then. By fine, I mean that I had media.autoplay.enabled set to false, and previously, right click on gifv -> select "Play" option from menu would play the gifv.

The workaround which works for me is: 
- Right-click on gifv.
- Select "Show controls" from shortcut menu. This puts (overlays) a big "Play" icon on the gifv.
- Press the big "play" button.
- Gifv now plays.

Reference imgur link: https://i.imgur.com/Iu78dcE.gifv

My setup: Win 10 x64, FF 52.0.2 (32-bit), a bunch of plugins (I can enumerate my plugin list if anyone wants it).

Also see the response by user "ObscureCulturalMeme" in this reddit thread: https://www.reddit.com/r/firefox/comments/649syo/any_new_config_stuff_regarding_imgur_videos_or/

Comment 14

a year ago
This seems to be fixed in FF 53.  At least, RtClick->Play does, which is all I care about :-).

(Doesn't seem to be assigned to anybody, so it'll probably stay open for another two years...)
Thanks for testing!
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED

Comment 16

a year ago
I have the same issue with Firefox 54.0 (Ubuntu).

This link won't play:

http://i.imgur.com/D3Drnvv.gifv

If I remove the 'v' from 'gifv' it works, but doing that each time is quite annoying.

Comment 17

8 months ago
for me this doesn't work if Mozilla Lightbeam extension is installed https://i.imgur.com/z8SSxba.gifv

Comment 18

8 months ago
Disregard that
You need to log in before you can comment on or make changes to this bug.