[flatfish] Build break due to BT_PROPERTY_REMOTE_VERSION_INFO is not defined in Android 4.2.2 HAL API

RESOLVED DUPLICATE of bug 1123077

Status

RESOLVED DUPLICATE of bug 1123077
4 years ago
4 years ago

People

(Reporter: shawnjohnjr, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

../../../gecko/dom/bluetooth/bluedroid/BluetoothHALHelpers.h: In function 'nsresult mozilla::dom::bluetooth::Convert(bt_property_type_t, mozilla::dom::bluetooth::BluetoothPropertyType&)':
../../../gecko/dom/bluetooth/bluedroid/BluetoothHALHelpers.h:201:6: error: 'BT_PROPERTY_REMOTE_VERSION_INFO' was not declared in this scope
     CONVERT(BT_PROPERTY_REMOTE_VERSION_INFO,PROPERTY_REMOTE_VERSION_INFO)
      ^
../../../gecko/dom/bluetooth/bluedroid/BluetoothHALHelpers.h:202:3: error: name used in a GNU-style designated initializer for an array

BT_PROPERTY_REMOTE_VERSION_INFO is not defined in Android 4.2 (API level 17) but it appears in Android 4.3 (API level 18).
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1123077
You need to log in before you can comment on or make changes to this bug.